Mouse click by position fails after upgrade to 2.0.6

hi @ashapkina, i tried on 3 browsers & different pc but the mouse arrow doesn’t move at all.

@ashapkina any updates?

@ashapkina I tried using a simple project with the mouse click and the mouse moved to the position.

However when i used it when number format and constant value, the mouse doesn’t moved at all. Have I done any steps wrong? There wasn’t any error as well.

Can anyone please advice me. Thank you so much.

@Kinalina sorry for delay. We have investigated it, and it looks like there is a bug in mouse actions with coordinates. We have created a ticket to fix it.

Ahh…I see, okay.
Would there be any workaround or have to wait for the fix (cos can’t use xpath) :sweat_smile:

@Kinalina there is no ETA for fixing this issue.

If you need to click on coordinates in a browser please use this approach:

  • Open website
  • Switch to the window and click on coordinates inside Window action
  • Switch to browser and use Web element actions and clicks on XPath there

Mouse action by position in web drivers are no supported. To click on a web browser window by position, first switch to it using Window action.

Hi @ashapkina- I have my mouse click by position inside a loop. Do I need to come out of the loop then->Switch to window-> Switch back to execute mouse click by position?

Do you have the loop inside Open website action so you cannot use the Window action inside it?


In this case, try clicking on the pop up using image and then typing.

@ashapkina, yes, my loop is inside the web action which is why I can’t use window. But sorry, I didn’t follow the solution. Click on what pop up?

I thought your post was related to this issue you had

If it is not and you just need to click on the webpage, try using a click by image instead of the click by coordinates.

@ashapkina- ah sorry, not the same. But in this case, even the image is not working. Is there a way I can send you a private message with a screen recording?

Yes, you can send it via a direct message here on the forum.

Just did, not sure if I did it correctly though. Could you help check if the file was sent privately? :slight_smile:

1 Like

Yes, I have received it. Thank you

@SaurabNair looks like the application looks different from the image that you use in the action, so probably, the bot cannot find the image and fails.



Thanks @ashapkina, but why would the script green light that step if it can’t find the image?

It must be happening because of the Exception handling.

To test the script, move the actions out of the Exception handling block, and you will see at which step the script fails.

1 Like

Ah that makes sense. Let me try and get back :slight_smile:

1 Like

@ashapkina- you were right, it was an image recognition issue. I increased the size of the anchor zone and it worked fine! Thank you :slight_smile:

1 Like