Mouse Move/drag to image doesn't work on RPA 2.0.4

I want to move the mouse from one position to another on the screen.
I set some actions in the RPA recorder and try to run it.
But I cannot see the mouse cursor move from one point to another, the cursor keeps on the place where it was and never moves.

Hi @yangyanz, could you share your recording to see the details?

RPA 2.0 use window control as default, so I cannot create automatic recording scripts using RPA recording function. I tried to record, it only can record some window control scripts, How can I get back the function that record my actions with image recognition and mouse operations?

My requirement is to record mouse click-hold- drag and move operations in an android emulator, now in RPA 2.0.4 I cannot record it.
Then I tried to add some actions like mouse move to one position on the screen and then hold click, and drag to another position on the screen, then release the mouse. it seems the RPA is not working with those actions.

For example, for mouse move, I expect the mouse cursor is really moving when I replay the mouse move action.

Mouse moves are nor recorded by default.

You can change the settings (Window - Preferences - WorkFusion Studio - RPA Recorder) to record them

image

Window controls are used during recording by default, but all images are still recorded, and you can switch to the image option in the action.

image

Let me know if you still have this issue after these changes.

Thank you , I will try and let you know.

1 Like