Number formatting fails

Hello,

I am using excel as source for numbers. I am reading the number with ‘get cell value’ activity and then using ‘Number Format’ activity to convert the string to number. The source number in excel is 43525,89 (Nordic numbering format) and now when I utilize different preset format patterns it comes out as:

43525 (preset 0.00 + Finnish Locale)
43525 (preset #.00 + Finnish Locale)
43525.88999999999 (preset #.00 + English Locale) - this is also the same format how the system reads this from excel into temporary variable.

I wonder if there is some kind of bug here in the system.

Thanks.

This might be valuable information for anyone whose Locale has number formatting with comma as decimal separator and dot as thousands separator: You will need to set the computer locale to such that dot is the decimal separator for the number format activity to work appropriately.

For Workfusion: please fix this in upcoming releases.

Was maybe jumping the gun a bit with the resolution. In Studio this seemed to fix the issue however running the script in Control Tower the problem is still there. Could you please look into this.

@peke_robot do you need to get the Number in the same format as the String: 43525,89 ?

Yes - trying to get the number with two decimals as the number is related to monetary amounts ie. would need the two decimals but no more than that.

Issue seems to be in the control tower “Final Results” section. When I look into the “snapshot results” in excel the numbers seem to be ok. So two things needed to resolve this:

  1. set numbering to use dot as decimal separator
  2. ignore the ‘final results’ field in control tower and look into the snapshot results excel instead.

You may want to fix the control tower bug

Seems like also the snapshot result excel includes numbers in erroneous format. Could someone look into this why this happens in control tower.

@ashapkina

@peke_robot sorry for delay. Will look into this. Could you please share the details of Number settings on your computer?

Hello, Language = English (US); Region = English (UK); Decimal symbol = ‘.’; Digit grouping symbol = ‘,’; No of digits after decimal = 2; Display leading zeros = yes; Measurment system = Metric.

1 Like

Hello,

the issue arises when I read the value from Excel ie. the string from Excel is read in wrong format. And the formatting simply does not work.

Could you provide me a mail where to send the sample excel so you can reproduce the error? @ashapkina

Regards.

Please send it to me via a direct message here on the forum.

Any progress with this one?

Hello,

any progress with this? Please look into this as without fix quite regular value comparison requires awkward implementation to work out.

Thanks.

1 Like