OCR action , failed to execute OCR action


#1

I am getting below error in OCR action when i run the recorder. What could be the reason. doing OCR action in 4th step and this is the last step in recorder.

Error : Failed to execute Action OcrAction
java.lang.RuntimeException: Failed to execute Action OcrAction
at com.workfusion.studio.rpa.recorder.processor.ActionFlowPlayer.execute(ActionFlowPlayer.java:311)
at com.workfusion.studio.rpa.recorder.processor.ActionFlowPlayer.processAction(ActionFlowPlayer.java:256)
at com.workfusion.studio.rpa.recorder.processor.ActionFlowPlayer.lambda$1(ActionFlowPlayer.java:120)
at java.util.ArrayList.forEach(ArrayList.java:1249)
at com.workfusion.studio.rpa.recorder.processor.ActionFlowPlayer.lambda$0(ActionFlowPlayer.java:120)
at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1142)
at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:617)
at java.lang.Thread.run(Thread.java:745)


#2

Hi, @sharad_kumar
Please, show me the screenshot of your script with opened OCR action
Send me logs from
INSTALL_DIR \OCR\logs\rest


#3

rest.zip (6.7 KB)


#4

Can you also send application.properties
from INSTALL_DIR\OCR
and version number
rpaxwin.version in
INSTALL_DIR\RPA\wfagent


#5

@sharad_kumar,

please also post the screenshot of your OCR action here and if possible a zipped recording folder.

It might happen that you forgot to provide an image for OCR or to select a variable to put result to.

And if you are using an old RPA Express version (1.1.2 and less), you need to update to 1.1.3.


#6

Hi Azinchuk ,
i am currently using 1.1.3 version Of RPA express and i will tell all the process what i did in BP.
1)I opened one PDF File
2)Then I create one variable of type String to save ocr result.
3)Upto Opening the pdf it is working fine after that while doing ocr it takes some time and after that it is throwing Exception.
Because of some restriction in my machine i am unable to post the images.

My Use case is i want to open PDF File and i want to extract some information from PDF through OCR and i want to save that OCR Result Into Excel…
Previously i was used RPA 1.1.0 ,i am not sure about exact version ,there it was worked fine.But i was updated RPA to 1.1.3 version that time onwards it is throwing Exception…
And I have one more query,When i restart my machine then in tray section of windows machine WF Symbol got invisible and i searched in forum that I have to type Rpa Express in Search Box of windows but it didnt worked for my machine.Can You tell me any solution for this because, For getting WF Sign again in Tray i have to again reinstall the entire RPA Express…Currently i am working in Windows 10 and I am Using Rpa 1.1.3 version…
Thanks
Sharad Kumar


#7


#8

recording12.zip (86.7 KB)


#9

@sharad_kumar,

You have the 0 x 0 rectangle in OCR action as I can see. Maybe you need to click the image and re-define the Anchor and OCR areas.

You Anchor area is the same as OCR area - it is not recommended to do so.

Please check our guide - https://kb.workfusion.com/display/RPAe/OCR#OCR-AddImagestoRecording


#10

Hi azinchuk,
I already tried with different anchor area and ocr area but that also didnt worked.So at last i did this but this also didnt worked…


#11

@sharad_kumar,

This action should work fine with the following params:

Thanks for reporting this issue - we will do our best to fix it in the 1.1.4 release.


#12

is there any way to get the version 1.1.0?We have to proceed with the usecases.


#13

@sharad_kumar,

while RPA Express is still in beta, we do not support previous versions. And the 1.1.0 OCR will not work because its license has been expired.

Just try the solution above or wait the 1.1.4 release which comes around the 1st of August.

Sorry for any inconveniences and thanks for your feedback.


#14

Thanks azinchuk for your valueable suggestions.


#15

Hi Azin
Yesterday i was updated RPA Express as 1.1.4 but again i am facing same OCRException…and all my previous Business process showing version errors…I created new business processs and i tried for OCR but at the ocr step it stops and after some time it is showing OCR exception whatever above we discussed previously…and i did all the ways whatever we discussed in this topic…
Can you check once if i am doing any thing wrong?
Thanks & Regards
Sharad


#16

after opening your recording in a new version of RPA Recorder, it should automatically migrate the old .rpae file and create a backup copy of the old version.

See how it looks like for the 1.1.3 recording opened in 1.1.4:


#17

I too get an error when trying to use OCR. I was hoping 1.1.4 would fix it, but i’m still seeing “Failed to execute action OcrAction”


#18

yes version error got resolved…but ocr till now after updating Rpa version also i didnt worked…i will try again one more time if it will not work i will update You because i already did all the things in version 1.1.4 also…


#19

@sharad_kumar,

you are also writing the same in the other topic: Unable To Work With OCR

Can you please choose one topic and tell us which one we can close?


#22

Hi,

OCR is not working in 1.1.4 version ,what could be the reasons for that anyone can suggest ASAP?