OCR not running

Hi Team,

I have installed Intelligent Automation Cloud 2.4 on a VDI machine with OS 2016 Server. But the OCR component is not running there and It is showing Red symbol. I figure the issue is not with the license since this is a new version of RPA express, I am unable to troubleshoot the issue. Could you please help with this.

NOTE : RPA express is installed on Citrix server.

image
Thanks,
Kiran Talreja

Hi @kiran.talreja what error message does it show when you hover the cursor over the status icon?
Also, please share the OCR logs from C:\IntelligentAutomationCloud\OCR\logs.

Hi @ashapkina,

I am not getting error message when I hover the cursor over the status icon. PFA OCR logs.
ocr-rest.log (46.2 KB)

Thanks,
Kiran

Is it the only file you have in C:\IntelligentAutomationCloud\OCR\logs folder?

Hi @ashapkina,

In C:\IntelligentAutomationCloud\OCR\logs folder, I have only one subfolder i.e rest. In C:\RPAExpress\OCR\logs\rest. We found only 1 log file which was uploaded in the last post.

Thanks,
Kiran Talreja

1 Like

Hi @kiran.talreja

Could you please clarify what warning do you see when you hover over red indicator
image

And could you please follow these links and share results here (you can put them in some .txt file for example)
http://localhost:15580/api/v1/cloud/listLicenses
http://localhost:15580/api/v1/cloud/activeLicense

Hi @iostapuk/@ashapkina,

I don’t see any warning when I hover over the red indicator and I followed the suggested links and it shows site can’t be reached for the both the links.

Thanks,
Kiran Talreja

Hi @ashapkina/@iostapuk,

Any updates on the log assessment?

Thanks,
Kiran Talreja

Hi @kiran.talreja
Sorry for the late response.
Could you please clarify if you RPA Express was launched when you tried to open this link http://localhost:15580/api/v1/cloud/listLicenses ?

Hi @iostapuk,

Do you mean was RPA express already running when I tried to access this link?

Thanks,
Kiran

@kiran.talreja
Yes, that is what I’ve meant.:slight_smile:

Hi, is this still actual?

Hi @iostapuk,

The issue still persists.

@kiran.talreja Could you please open this link while your RPA Express is launched?

Hi @iostapuk,

Yes RPA express was already launched when I tried to open the link.

Could you please wait for like 5-10 minutes after RPA Express is launched and open these links again. Do you see the same thing?

I waited for 15 mins and then tried to access the given links. Still getting the same error. What all ports are needed to be open to use ocr services in studio/rpa express.

@kiran.talreja

OCR uses port 15580. Make sure that it is closed to any external interaction. Let me know about your results

Do I need Port Opening for the same. I couldn’t understand ‘closed to any external interaction’ phrase. Can you please explain

It should be opened and not used by any other application.