OCR not working properly

I am trying to do OCR on scanned images. Following is the code:

<?xml version="1.0" encoding="UTF-8"?>
<config xmlns="http://web-harvest.sourceforge.net/schema/1.0/config" scriptlang="groovy">
	
	<var-def name="documentContent">
		<http url="${document_link}" />
	</var-def>
	
	
	<var-def name="region">
		<template>
			[
					{
						"type": "BT_Checkmark",
						"page": 1,
						"left": 860,
						"top": 1930,
						"right": 940,
						"bottom": 1975,
						"name": "Compute",
						"checkmarkConfiguration": {
							"type": "CMT_Square"
						}
					},
					{
						"type": "BT_Checkmark",
						"page": 1,
						"left": 860,
						"top": 2010,
						"right": 940,
						"bottom": 2055,
						"name": "Storage",
						"checkmarkConfiguration": {
							"type": "CMT_Square"
						}
					},
					{
						"type": "BT_Checkmark",
						"page": 1,
						"left": 860,
						"top": 2085,
						"right": 940,
						"bottom": 2130,
						"name": "Aruba",
						"checkmarkConfiguration": {
							"type": "CMT_Square"
						}
					},
					{
						"type": "BT_Checkmark",
						"page": 1,
						"left": 860,
						"top": 2160,
						"right": 940,
						"bottom": 2205,
						"name": "Pointnext",
						"checkmarkConfiguration": {
							"type": "CMT_Square"
						}
					}
				]
				
		</template>
	</var-def>
	
	<var-def name="ocrResult">
		<ocr profile="documentConversion" custom-regions="${region}" allowed-region-types="BT_Table, BT_Text,BT_Checkmark" export-format="xmlForCorrectedImage,html" remove-garbage-size="1"  remove-noise-models="2" >
			<ocr-image>
				<var name="documentContent"/>
			</ocr-image>
		</ocr>
	</var-def>
	
	<var-def name="ocrXML">
		<script return="xmlString"><![CDATA[
		xmlString = new String(ocrResult.get(0).wrappedObject.results['xmlForCorrectedImage']);
		]]></script>
	</var-def>

    <export include-original-data="true">
    	<single-column name="xml_link" value="${ocrXML}"></single-column>
    </export>

</config>

However, one image gives correct output but the other image does not.
Have uploaded part of the image for reference.
1 2

Hi @tanvi.lad are you using RPA Express or SPA for this task?