OCR outcomes and conditions


I’ve built a Business Process that includes 3 simple tasks: the first does the authentication on the application, the second executes and validates the action and the last task uses OCR to determine if the process continues or ends. The picture below shows the design of the process:

I want the business process to end If the number that the OCR captures is equal to 0 as shown in the pictures below:

As you can see in the first image, it is suppose to execute 2 queues, and then end, but it becomes stuck in the second task since there are no more queues to execute.

My first impression is that the OCR doesn’t recognize the 0, so I need to know if I’m doing everything ok.

Can you help me with this please?

Thank you

Does the OCR read correctly other values in that area like a 1 o 2? It could be that your anchor area is too small. It doesnt show in the screenshot you sent. I recommend using as anchor area a square that doesnt change in each transaction, like the area around
Quality Check

Could also be that OCR reads an O instead of a 0. You can solve that by using text replace action: search for O and replace by 0.

I also thought about that so I ran the OCR task on the RPA recorder and write the text captured in the OCR to a notepad, and Its does recognize everything correctly (0, not O, 1 and 2).

So if the problem isn’t in capturing the image, it has to be something related to the conditions and outcomes.

I’m thinking maybe the action flow is incomplete.

Is this enough for what I’m asking or do I need to add actions to the process?

I never work with the control tower, always only within the rpa recorder. If you join your actions (authentication, execution, OCR and check condition) into one recorder script and run the script from the recorder, does it work correctly?

To join the recordings:

Even If they work all together in the RPA recorder, which I guess they do since they also work separately, the problem comes when I run it as a business process in the control tower.

I’m almost sure the problem comes from the business rule OR the OCR actions flow is incomplete, I just don’t see how.

I appreciate your effort to find the solution tho!

The OCR step is fine, all it returns is the “text_from_ocr” variable which you then use in your condiiton check. I believe you followed also the recommendaiton from this post regarding the variable definitions between the different processes:

I think I understood what he meant properly. I added the “text_from_ocr” variable to the first and second task.

Still didn’t work.

Not sure if I did this right, but saved my time. on each bots I put this clean up steps for my text variables. Please check if this helps you


Sorry I don’t see how this can help me.

Thank you anyways!

What value do you have in the variable? Is it 0 or 0 ?


It’s 0.

CSV: “submissionUUID”,“start_date”,“author”,“text_from_ocr”,“pw”,“user”,“text_from_ocr confidence”,“author confidence”,“pw confidence”,“user confidence”,“start_date confidence”,“text_from_ocr accuracy”,“author accuracy”,“pw accuracy”,“user accuracy”,“start_date accuracy”
“02c25517-7d10-4c4a-b7ee-c7c60c9b22ff”,“Thu Feb 22 15:22:43 UTC 2018”,“workfusion”,“0”,“papersoft”,“goncalo.vasconcelos”,"-1 out of 0","-1 out of 0","-1 out of 0","-1 out of 0","-1 out of 0",“0%”,“0%”,“0%”,“0%”,“0%”