Open Spreadsheet + Set Active Cell does not work inside loops - 1.1.6

excel-loop
excel
set-cell-value
issues

#1

Hi,
I upgraded to version 1.1.6 to solve the bug, but i still have the same error than in the version 1.1.5.The bug was reported and I thought that the new version will fix that.

But I still have the same error, I only can run the script one time in a loop the second time in the loop it stops.

Also i have reinstalled the 1.1.4 version and then my scritps works fine.

Here images of the error in the new version (1.1.6):


#2

@joreian,

You can drag the Open Spreadsheet action outside the For Each loop - no need to open the same file many times.

We are planning to fix your case in the nearest time.


#3

@azinchuk
I need to get the data from an excel document and use it on a web page.
I have to do it several times since each row of the document is a new process of the web (with different inputs).

How should I do it with version 1.1.6?

Thanks.


#4

I am having the same issue. Tried to mimic the variables and loops training video. Does not work after the 1st cell is set. Using version 1.1.5.


#5

I have the same problem.

Other point. I have been creating a condition (If-else), comparing two rows in Excel. In my computer and control tower it work well. But when I developed the workflow inside control tower, with all my projects and it stopped to recognize the conditions, true or false was the same (always false). My intention is schedule the workflow.


Can't use action library "loop" well
#6

image This error is showing up randomly… Open Spreadsheet Action execution error…


#7

@joreian

We’ve released a new fix for your issue - please download and install a new version using the same link


#8

Ohh thanks, I just installed a VM on my computer in order to use the 1.1.6 version and the 1.1.4 version at the same time.

If the fix works, this will be better than using a VM.

I will try it tomorrow. :grin::grin:


#9

Hi ,

i am getting error while writing the data by using for each loop.

i have input file and same input file reading and writing to new xlsx file.while running script i am getting error.


#10

Hi @suresh.golla,

Could you please clarify what the error is? I kindly ask you to provide us with the screenshots and the log file.

Thank you,
Nurzhan


#11

@suresh.golla
Please get acquainted with our Forum Guidelines, in particular, the section How to Ask a Good Question (Create Topic) > WorkFusion Forum Guidelines

This way will be able to assist you more efficiently.
Thank you.

-Nataliya


#12

Hi have created small example to read xl file and write same data to new xlsx file, when i was writing by using for each loop i am getting error.

plese find below screenshot for your reference.


#13

hi @suresh.golla,

this issue is fixed in the latest release. Please download the latest version using the same link.


#14

Hello my problem has been solved with the lastest version.

@azinchuk Thanks!!