Open Website action doesn't close the browser window

actions_flow_s
problem_s
issues
#1

Hello.

Recently I encountered a problem with the newest version - Open website action doesn’t close the browser window after performing all actions on that website. The next open website action doesn’t work after that and the robot is stuck within that step. I can’t turn it off - I have to restart the computer because workfusion loses connection to the bot. The problem occurs on multiple laptops and user profiles.

image

#2

Hi @Piotr
Could you please clarify if you mean version 2.3 of RPA Express?
Also could you please send your .rpae project where the issue occurs or send a screenshot of your actions flow at least?

Thanks.

#3

Version 2.3. Unfortunately I cannot send you the project. The issue occurs every time after opening the website for a second time, it doesn’t matter on which step I start the robot.


To simplify - robot opens a website, performs some actions on it then performs actions in other windows such as Citrix and Excel and after that it tries to open a website again. At that moment it fails and cannot be turned off.

#4

Hi again @Piotr
Does it happen in some specific browser or in any browser?

#5

Internet Explorer is the only one we can currently use.

I’ve tried to create a new project with few open website actions in a row and it worked fine. It seems the problem occurs in that particular robot for some reason. I’ll try to copy these steps to a separate project and check if they work there once I finish other work.

#6

@Piotr Thanks for information. Let me know about your results:)

#7

It didn’t work, so the problem is probably with the combination of actions. I’ll try to figure it out whenever I have time but I’d appreciate some ideas on how it could be potentially solved.

#8

Hi again @Piotr. So the are no exceptions, it just freezes? Also have you tried to run this script on another machine? Does it work?

#9

Hi @Piotr is the issue still actual?

#10

Hi @iostapuk. Thanks for the interest. I didn’t respond because I wasn’t entirely sure if it’s solved however it seems the problem was a download window that was opening within the “open website” action" and it has to be closed. So far it works, I’ll let you know if it breaks. Currently I have to work on something else with higher priority so I cannot run more tests.

1 Like
#11

@Piotr Thanks for sharing and keeping me updated:)