Open Website Not working

Same issue here. Keep getting “Time out” error as pasted below. Another issue is that i dont see website load timeout setting in preferences.

Timed out waiting for page load.
Build info: version: ‘2.53.0’, revision: ‘35ae25b1534ae328c771e0856c93e187490ca824’, time: '2016-03-15 10:43:46’
System info: host: ‘KGAUR’, ip: ‘10.146.223.57’, os.name: ‘Windows 10’, os.arch: ‘amd64’, os.version: ‘10.0’, java.version: '1.8.0_121’
Driver info: driver.version: unknown
Command duration or timeout: 11.29 seconds
Build info: version: ‘2.53.0’, revision: ‘35ae25b1534ae328c771e0856c93e187490ca824’, time: '2016-03-15 10:43:46’
System info: host: ‘KGAUR’, ip: ‘10.146.223.57’, os.name: ‘Windows 10’, os.arch: ‘amd64’, os.version: ‘10.0’, java.version: '1.8.0_121’
Driver info: com.freedomoss.crowdcontrol.webharvest.selenium.wrapper.RemoteDriverWrapper
Capabilities [{sikuliThreshold=0.8, webdriver.remote.sessionid=3e9b718d-badd-48d8-a9c1-fabf9594f61f, browserName=universal, takesScreenshot=true, javascriptEnabled=true, SEARCH_ALL_WINDOWS=true, platform=WINDOWS}]
Session ID: 3e9b718d-badd-48d8-a9c1-fabf9594f61f
org.openqa.selenium.TimeoutException: Timed out waiting for page load.
Build info: version: ‘2.53.0’, revision: ‘35ae25b1534ae328c771e0856c93e187490ca824’, time: '2016-03-15 10:43:46’
System info: host: ‘KGAUR’, ip: ‘10.146.223.57’, os.name: ‘Windows 10’, os.arch: ‘amd64’, os.version: ‘10.0’, java.version: '1.8.0_121’
Driver info: driver.version: unknown
Command duration or timeout: 11.29 seconds
Build info: version: ‘2.53.0’, revision: ‘35ae25b1534ae328c771e0856c93e187490ca824’, time: '2016-03-15 10:43:46’
System info: host: ‘KGAUR’, ip: ‘10.146.223.57’, os.name: ‘Windows 10’, os.arch: ‘amd64’, os.version: ‘10.0’, java.version: '1.8.0_121’
Driver info: com.freedomoss.crowdcontrol.webharvest.selenium.wrapper.RemoteDriverWrapper
Capabilities [{sikuliThreshold=0.8, webdriver.remote.sessionid=3e9b718d-badd-48d8-a9c1-fabf9594f61f, browserName=universal, takesScreenshot=true, javascriptEnabled=true, SEARCH_ALL_WINDOWS=true, platform=WINDOWS}]
Session ID: 3e9b718d-badd-48d8-a9c1-fabf9594f61f
at sun.reflect.GeneratedConstructorAccessor126.newInstance(Unknown Source)
at sun.reflect.DelegatingConstructorAccessorImpl.newInstance(DelegatingConstructorAccessorImpl.java:45)
at java.lang.reflect.Constructor.newInstance(Constructor.java:423)
at org.openqa.selenium.remote.ErrorHandler.createThrowable(ErrorHandler.java:206)
at org.openqa.selenium.remote.ErrorHandler.throwIfResponseFailed(ErrorHandler.java:158)
at org.openqa.selenium.remote.RemoteWebDriver.execute(RemoteWebDriver.java:646)
at org.openqa.selenium.remote.RemoteWebDriver.get(RemoteWebDriver.java:284)
at com.workfusion.rpa.helpers.RPA.openFirefox(RPA.java:496)
at com.workfusion.studio.rpa.recorder.model.action.web.OpenURLInFirefoxAction.executeAction(OpenURLInFirefoxAction.java:33)
at com.workfusion.studio.rpa.recorder.model.action.ActionWithDelay.execute(ActionWithDelay.java:26)
at com.workfusion.studio.rpa.recorder.processor.ActionFlowPlayer.execute(ActionFlowPlayer.java:283)
at com.workfusion.studio.rpa.recorder.processor.ActionFlowPlayer.processAction(ActionFlowPlayer.java:222)
at com.workfusion.studio.rpa.recorder.processor.ActionFlowPlayer.processAction(ActionFlowPlayer.java:186)
at com.workfusion.studio.rpa.recorder.model.action.BaseNestedAction.executeAction(BaseNestedAction.java:22)
at com.workfusion.studio.rpa.recorder.model.action.ActionWithDelay.execute(ActionWithDelay.java:26)
at com.workfusion.studio.rpa.recorder.processor.ActionFlowPlayer.execute(ActionFlowPlayer.java:283)
at com.workfusion.studio.rpa.recorder.processor.ActionFlowPlayer.processAction(ActionFlowPlayer.java:222)
at com.workfusion.studio.rpa.recorder.processor.ActionFlowPlayer.processAction(ActionFlowPlayer.java:186)
at com.workfusion.studio.rpa.recorder.processor.ActionFlowPlayer.lambda$3(ActionFlowPlayer.java:104)
at java.util.ArrayList.forEach(ArrayList.java:1249)
at com.workfusion.studio.rpa.recorder.processor.ActionFlowPlayer.lambda$0(ActionFlowPlayer.java:104)
at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1142)
at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:617)
at java.lang.Thread.run(Thread.java:745)

which version of RPA Express are you using?

version 1.0.0

@kuldeepgaur, please re-register at http://www.workfusion.com/rpaexpress - you will get a constant link to the latest RPA Express release (current version is 1.0.2)

Hello azinchuk,

I am receiving this error message as well, these are my detailed error logs from the message:

Timed out waiting for page load.
Build info: version: ‘2.53.0’, revision: ‘35ae25b1534ae328c771e0856c93e187490ca824’, time: '2016-03-15 10:43:46’
System info: host: ‘DESKTOP-QD5UL6T’, ip: ‘192.168.86.22’, os.name: ‘Windows 10’, os.arch: ‘amd64’, os.version: ‘10.0’, java.version: '1.8.0_121’
Driver info: driver.version: unknown
Command duration or timeout: 15.40 seconds
Build info: version: ‘8.3.5-SNAPSHOT’, revision: ‘unknown’, time: '2017-06-14 10:10:21’
System info: host: ‘DESKTOP-QD5UL6T’, ip: ‘192.168.86.22’, os.name: ‘Windows 10’, os.arch: ‘amd64’, os.version: ‘10.0’, java.version: '1.8.0_121’
Driver info: com.freedomoss.crowdcontrol.webharvest.selenium.wrapper.RemoteDriverWrapper
Capabilities [{sikuliThreshold=0.8, webdriver.remote.sessionid=6d17e2c4-3d9d-42f9-a6d1-a7eab644d615, CLOSE_ALL_WINDOWS=false, browserName=universal, takesScreenshot=true, javascriptEnabled=true, SEARCH_ALL_WINDOWS=true, platform=WINDOWS}]
Session ID: 6d17e2c4-3d9d-42f9-a6d1-a7eab644d615
org.openqa.selenium.TimeoutException: Timed out waiting for page load.
Build info: version: ‘2.53.0’, revision: ‘35ae25b1534ae328c771e0856c93e187490ca824’, time: '2016-03-15 10:43:46’
System info: host: ‘DESKTOP-QD5UL6T’, ip: ‘192.168.86.22’, os.name: ‘Windows 10’, os.arch: ‘amd64’, os.version: ‘10.0’, java.version: '1.8.0_121’
Driver info: driver.version: unknown
Command duration or timeout: 15.40 seconds
Build info: version: ‘8.3.5-SNAPSHOT’, revision: ‘unknown’, time: '2017-06-14 10:10:21’
System info: host: ‘DESKTOP-QD5UL6T’, ip: ‘192.168.86.22’, os.name: ‘Windows 10’, os.arch: ‘amd64’, os.version: ‘10.0’, java.version: '1.8.0_121’
Driver info: com.freedomoss.crowdcontrol.webharvest.selenium.wrapper.RemoteDriverWrapper
Capabilities [{sikuliThreshold=0.8, webdriver.remote.sessionid=6d17e2c4-3d9d-42f9-a6d1-a7eab644d615, CLOSE_ALL_WINDOWS=false, browserName=universal, takesScreenshot=true, javascriptEnabled=true, SEARCH_ALL_WINDOWS=true, platform=WINDOWS}]
Session ID: 6d17e2c4-3d9d-42f9-a6d1-a7eab644d615
at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method)
at sun.reflect.NativeConstructorAccessorImpl.newInstance(NativeConstructorAccessorImpl.java:62)
at sun.reflect.DelegatingConstructorAccessorImpl.newInstance(DelegatingConstructorAccessorImpl.java:45)
at java.lang.reflect.Constructor.newInstance(Constructor.java:423)
at org.openqa.selenium.remote.ErrorHandler.createThrowable(ErrorHandler.java:206)
at org.openqa.selenium.remote.ErrorHandler.throwIfResponseFailed(ErrorHandler.java:158)
at org.openqa.selenium.remote.RemoteWebDriver.execute(RemoteWebDriver.java:646)
at org.openqa.selenium.remote.RemoteWebDriver.get(RemoteWebDriver.java:284)
at com.workfusion.rpa.helpers.RPA.openFirefox(RPA.java:424)
at com.workfusion.studio.rpa.recorder.model.action.web.OpenURLInFirefoxAction.openUrl(OpenURLInFirefoxAction.java:21)
at com.workfusion.studio.rpa.recorder.model.action.web.AbstractOpenURLAction.executeAction(AbstractOpenURLAction.java:33)
at com.workfusion.studio.rpa.recorder.model.action.ActionWithDelay.execute(ActionWithDelay.java:27)
at com.workfusion.studio.rpa.recorder.processor.ActionFlowPlayer.execute(ActionFlowPlayer.java:317)
at com.workfusion.studio.rpa.recorder.processor.ActionFlowPlayer.processAction(ActionFlowPlayer.java:256)
at com.workfusion.studio.rpa.recorder.processor.ActionFlowPlayer.lambda$1(ActionFlowPlayer.java:120)
at java.util.ArrayList.forEach(ArrayList.java:1249)
at com.workfusion.studio.rpa.recorder.processor.ActionFlowPlayer.lambda$0(ActionFlowPlayer.java:120)
at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1142)
at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:617)
at java.lang.Thread.run(Thread.java:745)

I have version 1.1.2

I hope you can help me with this asap.

@Robert_Booth
please, set Web timeout to
in Window -> Preferences

1 Like

Thank you.

However, is there any functionality to allow for a more dynamic way of handling this instead of using a standard timeout w/ a fixed time?

Its not a standard timeout, its a max time driver is going to wait for page to load.
If you set it to 100s, but website was loaded in 3s, its not going to wait additional 97s.

Apologies, I should have clarified.

I understand that is how it works. For some reason though, the Firefox Portable isnt loading at all and is staying in a loading state whilst the page is clearly visible.

In this screenshot, you can clearly see that the page is loaded but the status at top left indicates it is still loading items in background.

However, it stays like this for minutes at a time.

No problem.

For this actions we use Selenium.
And selenium needs whole page to load, it waits for the very last api call/request, and only then it marks page as “loaded”

Thanks for the information.

So I need to use Selenium instead for this? I have meddled with it prior but want to be clear that this is just a limitation with Express.

No, this is the way it works. Page needs to be loaded

However, I guess my question is if page continues to not load then I will either have to use Selenium which has this requirement as default or set timeout propertty to such a high number that it will account for any/all load times?

You will have to increase timeout.

I have the same issue too. Have tried increasing the global time-out to 100,000 but it does not work. I can see the webpage but it shows it is still loading…

@Robert_Booth @tang_kah_heong - please try to automate other websites (not yahoo), because this website is constantly streaming video, so your page might be not loaded for minutes.

Hi @azinchuk ,

We are trying to use open websiteaction, initially it worked but after few iteration it stopped working.
In RPA recorder it’s showing for this action while executing. The firefox browser got opened but it didn’t launched the website and exit from that.
PFA.


@Harshit_Jain
as you can see from the error log, you are trying to open a web-site on your local host via the specific port. Is it the correct address or not? Please let us know more details.

I am facing the same issue not able to open any website using Open website action. Earlier it was working fine suddenly got stopped. Not even entering the URL in address bar.

Hi, @Harshit_Jain, @sivaramakrishna.mangisetty

Please run script 1 more time, then go to INSTALL_DIR\RPA\logs
and send rpa-node0 logs (from today, latest modified file)