Optimal production setup?

What would the optimal setup be for production environment so that it would function completely ’on background’ without need for open screen connection.

Now to overcome that we have Workfusion installed on a server and have RDP connection on to enable e.g. mouse clicks etc. And for security measures we have locked the screen of the machine from which the RDP connection is established.

However keeping RDP connection on continuously is somewhat unreliable approach. E.g. server updates disconnect the RDP connection.

Any guidance would be highly appreciated!

Hi @peke_robot.
Usually if you’re using image-based actions in your script, you need to have RDP connection opening in order bot can find and recognize necessary elements. But you can try to use Web-elements with XPath.

Also please advise which RPA Express version is installed on your machine and which installation type: Server + Workstation, only Server or only Workstation.

I have Server+Workstation setup on Windows Server 2016. Is it possible to set that up somehow so that as default the processes are launched on RDS instead of local screen.

The issue with the current setup is that there needs to be either local terminal window or RDP connection from outside machine open for the scripts to function. And no, the scripts are not image-based. With Windows Server 2008 it was still possible to transfer the RDS session from external machine back to the server itself, but it does not work with the more recent servers.

Regards

In the free version, you cannot launch bots in the remote window, only locally.
Remote bots are only available in the RPA Express Pro subscription.

With the Pro version is it possible to launch the bots on remote window by default so that no local window is used even if there would be only one process running?

Yes.
If you have the Sever component installed separately (with Workstation installed on another machine), the local bot on the server isn’t installed at all, and all processes run in the background.

If you have Server+Workstation setup on the same machine, you can stop the local bot and only use remote ones.

Hello,

the latter is the one I have been looking after. How do I disable the local bot?

Regards

You need to change the app settings:

in the file C:\RPAExpress\RPA\wfagent\settings\local_bot.yml, change the value of property startup to false.

image

Will test this asap.

1 Like