Play recording failure

I am in the midst of evaluating Work Fusion Express for my company. Using Version 2.1-beta now.

I started by doing simple recording and playing the recording as follows.

Evaluation 1:

  1. I evaluated by recording the login process to a web application. Recording seemed ok but playing it failed. It seemed to fail to recognise the web application as web application. It’s treated as a windows application. So, it failed miserably. Is there somewhere I have to specify it’s a windows application or a web application?
  2. I deleted the entire recording and manually “coded” it using xpath based on my experience in robot framework. It worked.

Evaluation 2:

  1. I evaluated by recording double clicking of MS Word shortcut on my desktop. Then chose a blank document. Keyed in some text. Closed MS Word without saving the file. Recording seemed ok but when playing back, again it failed. It failed at double clicking the MS Word shortcut. I had re-recorded multiple times without any success in playing back the recording. The detailed error message of Java was not that useful at all. I am still clueless on why such a simple double clicking could fail. The selector as follows looked strange to me because I didn’t click or hover on the Sticky Notes. It should be showing something about MS Word rather than Sticky Note:

[CLASS:HwndWrapper[StickyNotes.Wpf.exe;;;;50a05ef6-b0e6-414c-bcc2-966f49b86f44]; NAME:Sticky Notes; TEXT:Sticky Notes]

I have no idea why it’s picking up Sticky Notes instead of MS Word. Is it a bug of Work Fusion Express?

Hi @leansiang_yew

Thank you for the feedback.

In the recorder mode, window controls are recorded by default as it is the most stable way to work with windows applications. But they only work with Windows applications and cannot access elements inside web pages. In web, we recommend switching the location to image or - the best way - to use Web actions. They are not recorded automatically, so you have to add these actions to the flow manually.

As for the issue with the MS Word shortcut, try opening the Inspector and inspect the shortcut using the “Capture” option. What selector does it show in this case?

1 Like

Thank you very much for the information.

Yes, the inspector actually helps a lot to fix the problem in windows app painlessly :slight_smile:

I actually found an alternative solution prior to your response by using image but I think it’s not a very reliable solution in case the image is slightly changed.

Thanks again.

1 Like

By the way, I cannot seem to copy and paste the value of selector from inspector to the selector of Click Mouse. I tested by copying the value of selector from inspector to notepad, there’s no issue. So I believe it was a problem in pasting at Click Mouse. I am in Windows 10 environment.

Could you please confirm this? Thanks.

I just tried it on a Windows 10 pc, and it worked. Can you paste it using right click - paste?

Thanks. It’s ok. I think it’s my laptop issue. I tried it in the evening when sharing my evaluation with my colleagues, it seemed to work at that point of time.

1 Like