Problem in recording!

Hi Team

Recording script working fine, sometimes it stops automatically with error message but it works perfectly previously or after play when error occurs.

It will creates problem when I show demo to someone or it happen in-between the process.

Please suggest.

Thanks
Ajay

Suddenly stop execution and getting error after sometime.

When i tried again, it works perfectly.

What happen to recording ?

Please suggest.

Unexpected Error Occurs

I don’t know, what the issue.

Here is the one screenshot.

@Ajay_Singh_Rawat6

Hi Ajay, what are your PC specs? What is the amount of free RAM and disk usage?

@ashapkina

Hi Alesia

Right now, bots are not running.

Below are the screenshots.

PC Specs

pc_specs

Ram Usage

ram_usage

Disk Usage

disk_space_usage

Thanks
Ajay

@Ajay_Singh_Rawat6
please play the recording again and when the error occurs send us the logs (hub, node, and recorder logs), we’ll take a look: https://kb.workfusion.com/display/RPAe/Troubleshooting#Troubleshooting-HowtoSendLogs

Also, does the recording always stop at this step, or at different steps?
If it is always the openURLaction, please check that the timeouts are set. Do you use IE or Firefox?

@ashapkina

Alesia, there is some sensitive data. So please suggest how and where i can send it to you.

No, the recording always stop at different steps or sometimes same step.

But sometimes it works perfectly.

I am using firefox portable, which is in “Open Browser”.

Thanks
Ajay

@Ajay_Singh_Rawat6
If you don’t feel like posting them here in the thread, you can send them to me in a private message.

@ashapkina

From where I can send a private message

@Ajay_Singh_Rawat6
Are you using the version of Firefox portable that was installed with RPAe or did you update it?

@ashapkina

Using the version was installed with RPAe.

@Ajay_Singh_Rawat6 try increasing the timeout. Does the error still occur?

@ashapkina

Are you talking about this?

timeout

@Ajay_Singh_Rawat6

Increase it in RPA Recorder global settings (Window-Preferences) and leave the settings in the action properties blank.

@ashapkina

global_setting

Right now, in timeout duration is 5000.

Should I set to 10000?

timeout

and set 0 in Wait up to 0 milliseconds

Am I right?

Thanks
Ajay

@Ajay_Singh_Rawat6
yes, that’s right

@ashapkina

Setting done.

I have too many processes, that’s why it take 8-12 minutes.

Let me check and get back to you.

Thanks
Ajay

@ashapkina

I tried process by running script, but getting same issue with different steps.

Once in a while, it works perfectly.

I am worried for the process abundant. :frowning_face: :fearful:

@Ajay_Singh_Rawat6

Ajay, please send us zipped logs at C:\RPAExpress\RPA\logs. We’ll see if we can find something there.
Are sure that Firefox didn’t update? RPAe currently uses version 46.0.1.

@ashapkina

Sending zip logs file to private message.

No didn’t update Firefox.

Here is attached screenshot.

firefox_version

Thanks
Ajay