Process Running in Recorder, Failing in Control Tower

Hello,

I’ve got a process that is supposed to loop until an image is found. For testing purposes, the program should loop five times before it finds the image. In the RPA Recorder, it is looping correctly, but when I publish it to Control Tower, it only iterates one time, then leaves the loop as though it had found the image (which isn’t possible).

The piece of code is pretty simple, a while statement: while (found = “false”)
Followed by two mouse clicks.
Then wait for image and store the outcome in variable found.

Could you share your recording?

Could you zip and send the folder with the recording so we could see the details (the images used etc.)?

@ashapkina, I cannot upload most file types (including zipped folders) for confidentiality reasons due to using a work laptop, .jpeg is pretty much the only file type I can upload.

@ashtonmohns okay, will try to reproduce it using a similar scrip. Could you share the details of the Wait for Image action?

Sure, see attached.

1 Like

@ashapkina, any update on the problem?

@ashtonmohns I tried to reproduce such issue on a similar script, but it worked in Control Tower.
Could you share a couple of examples of how the excel file will look during the first iterations?
Thank you.

@ashapkina For testing the program, I have the attached file. Eventually, I will be using more of the columns, but for testing the Excel portion, I’ve only used the first one.

Hello @ashapkina,

I tried running the process again in the Recorder, and now it seems to be failing there as well. I haven’t changed anything in the script since I first started this post.

Basically, it clears the first row, then the variable excel_is_clear becomes true (though it shouldn’t) and the loop ends. Any idea why this would be?

Thanks,
Ashton.

@ashtonmohns try increasing the Image matching threshold: Window - Preferences - WorkFusion Studio - RPA Reorder.

image

By default, it is set to a lower level, so it might detect a similar image to the image the bot is looking for.

@ashapkina, that seems to have fixed the problem. Thanks for the help.

1 Like

Glad it helped :slightly_smiling_face: Sorry it took a long time to figure out.