PU L1 - Assignment 2 - Run the process


#1

Please use this tread for all of your questions of Power User - Level 1 - Assignment 2 - Run the process.


#2

Hi,
In the instance vr1684, while doing PU L1 Assignment #2, I’m unable to complete the manual task because the invoices are not displayed. It is showing the following error in the left panel “Input data is incorrect. We apologise for the inconvenience”.


#3

Hi,
You should change the unique key name according to generated column name.
i.e here you need to change it to document_html_link.


#4

Hi,
I tried by changing it earlier. But, even then it didn’t work


#5

Hi @vijayanand

Can you share a link on the process?


#6

Hi @YShilyaev_Workfusion Please find the link below.

https://vr1684.workfusion.com/workfusion/secure/business-process/edit/6fd596d3-b056-4a5e-ba56-dda41d6e3e90?actTab=WORKFLOW_DESIGNER


#7

@vijayanand

https://vr1684.workfusion.com/workfusion/secure/business-process/edit/6fd596d3-b056-4a5e-ba56-dda41d6e3e90?actTab=WORKFLOW_DESIGNER - please open Data tab. You can see all variables and data which you have in the process.
You’ve used in IE task this variable ‘document_xml_link’. OCR do not create this variable, you should use ‘document_html_link’ variable, which actually exist in your data:
https://s3vr1677.workfusion.com/temp.bucket/wf-ocr/6bbd1443-98b0-4c28-9a4d-d851383cfc50.html


#8

Its working. Thanks a lot @YShilyaev_Workfusion :slight_smile:


#9

The assignment has asked to use the attached data-file csv, but there is no attachment on the page.


#10

Warning! The use case you have selected does not correspond to some columns in the upload file. Map columns

I am experiencing a similar problem to what others have mentioned, except the solutions given do not seem to be applicible any more. I am not sure how to resove the issue.


#11

Hi Yury Shilyaev,

I have per the instruction downloaded and installed RPA Express and I decided to re-do the assignments again from the beginning.

So I downloaded the package as instructed for Assignment 2 and import it (i.e. OCR+IE+CSV (18-9-2017).zip) but when I preview the package the problem is that it wants to create a new version as it feels that an older version exists i.e. the Accounts Payable Business Process pre-installed with RPA Express.

So I create the new version and when I upload the data file invoices_pic.csv we get the error “Warning! The use case you have selected does not correspond to some columns in the upload file.”.

Clicking on Map Columns yields the following:

What do I need to change so that it isn’t looking for the S3 fields?

Is it possible that the Package needs to change in the Assignment example?

Regards…/John


#12

@john_soares!

You’re right! Just changed a file, please download the new one.


#13

Hi Yury,

The new CSV file with the new field name partially helped but there is still an error being flagged for the html_content field displayed below:

Hope this helps…/John


#14

@YShilyaev_Workfusion This is still unresolved, is there an eta on when this assigment will be ready? This is also impacting assignment 3 because that one copies what is created in 2.


#15

Hi All, I’m new to this forum. I faced an issue while creating and running my first business process (“Assignment 2: Run the process” Assignment). Followed all the mentioned steps and tried running twice. Kindly help. Attached the screenshots. Thanks in advance.



#16

Hi @YShilyaev_Workfusion . I am facing the same issue as stated by @janakirama.d . Could you please help in resolving it.


#17

Hi @shruti_kirti @janakirama.d

Please try to use this business process package. We found that in new RPAx ver, previous one doesn’t work.

OCR IE 13-10-2017.zip (20.1 KB)


#18

Hi @YShilyaev_Workfusion

Now I am getting the following error code:
10.13.2017 15:08:42
ERROR
20885
**

IO error during HTTP execution for URL: http://localhost:15580/api/v1/cloud//processImage.

**

Note : I am trying to import the package over my SPA control tower.


#19

@shruti_kirti

Oh, no. :slight_smile:
This package is only for RPAx. Please do not use it in SPA. :slight_smile:
For SPA please use another process:
In this assignment you will run your first process in WorkFusion and will see the results of bot’s execution.

Go to your WF Training Instance and login.
Create new Business Process
Use UseCase ‘Other’ -> 'Miscellaneous Tasks’
Upload the data-file (.csv) attached to this assignment.
Click 'Next’
Change the title of your Business Process. The title should contain:
Course
Assignment number
Your Name
Create a process:
Add Start and End points
Add SubProcess: ‘Process’ -> ‘WorkFusion training’ -> 'WF OCR Subprocess’
Add Human Task: ‘Manual’ -> ‘WorkFusion training’ -> 'Invoice Information Extraction’
Connect all the elements.
Run your business process.
Open WorkSpace-Sandbox, login and complete the manual task.
Watch the results and analyse them.

And you should use another doc-file.
invoices_pic.csv (388 Bytes)


#20

Thanks @YShilyaev_Workfusion !! I think now it will work perfectly. :slight_smile: