PU L1 - Assignment 2 - Run the process



Hi, I’m trying to use training instance(https://copernicus.workfusion.com), Created new business process and imported data. All looks good, I’m able to run process. But looks like it is failed to load images.
Error details:
Step name ‘Task - looking for the document at the OCR cache - BP OCR’ has failed. Reason: ‘IO error during HTTP execution for URL: https://s3vr1677.workfusion.com/trainings/invoices_scan/invoice4_scan.png’

Does anyone knows training instances are properly up and running? Any help appreciated.


Has it been fixed now! No I guess, Since I have same issues on Chrome.


This issue is still relevant. Does anybody have any solution?


I tried out to comment the function containing the problem XPath(and its call as well) and got the same error but with another XPath:
‘Error parsing XPath expression (XPath = [//response/task/@id])!’

So it seems like the root of this issue is not in the business process design but in execution engine.


Has anyone found the solution for this? I have same error when I run the workflow…


Also running into the same issue of “Step name ‘Transform invoice image to HTML page (OCR)’ has failed. Reason: ‘Error parsing XPath expression (XPath = [//task/@status])!’” If anyone has a solution it would be much appreciated

Not a great experience to try running the tool on the demo put out in your training and have it not work and then come onto the forum to see that others have been having the same issue and WF has not replied with a patch/solution for over a month since first reported


I have an issue with the PU L1 - Assignment 2 - Run the process
When I add invoice_pic_rpax.csv in OCR+++IE+13-10-2017 process this warning message appears:

After run the Process in logs error appears:

I have a latest version Control Tower and Workfusion 2.0. This issue reproduced at Google Chrome and FireFox too.
Please, help with this issue.


Hi, All! The issue with this process was fixed. Please, copy the new version of this BP in the assignment and run it. If error still occur, you have to rerun the RPA Express. Sorry for inconvenience!


I still have the same issue even after copying the new version of the BP and rerunning RPAx.


When I runned de business process, I just got some erros messages, all them with this description: "step name ‘Transform invoice image to HTML page (OCR)’ has failed. Reason: ‘Error parsing XPath expression (XPath = [//task/@status])!’ "


Hi, Angelo!
You have to use the latest version of RPA Express. What version are you currently using?


How can I Update de system ? My executable just take me to modify option


Hi! Please, read this KB article - https://kb.workfusion.com/display/RPAe/How+to+Update+RPA+Express


Tks , I got it. But, i had to download the executable from site. My old executable didn’t work.



I get below errors when I run the process. How can the issue be solved?


The business process runs fine but when I get to the manual tasks part and click “find these tasks in [Workspace]”, I get this message in the Workspace window " No more tasks of this type are available for you. Try to [find] other tasks in categories available for you". There aren’t any manual tasks in workspace, I used the search option also and it couldn’t find anything.

I found the following solution on one of the posts in the forum in April:

  1. I had to uninstall RPA
  2. Ran netfxrepairtool as it was mentioned in one of the posts by @SKulshrestha_PwC4
  3. Installed it back, this time instead of C driver, I did the installation under Program Files
  4. Did the exact same steps which I have been doing for the past day for creating manual task and viola! It worked.

Is this the only solution still valid today? I’d hate to unistall and install the whole thing again. I am using the latest version of RPA Express.


HI, I tried to uninstall, clean and reinstall the RPA (ver. 2.2) as suggested by bogdancam, but when executing the task still have the same issue as davlin wrote here above. The BP is not being executed and the corresponding Manual task is not being created.

Tried to Update the app but still the issue persist. Please suggest the fix.


Hi @gmryglo

do you use RPA Express 2.2.0?
Yesterday, the OCR license for this version expired. You need to update to a new version 2.2.1 to use OCR.


So update to the latest version through the previous file installer is not working? I did install the new version after uninstalling and cleaning the old one. After that indeed the BP started to work. It accomplished the bot task and sends me to the Workspace for accomplishment of a manual task.

But the manual task was not generated for my account.


What should be my next step, please?


Hi ashapkina again.

I was trying to investigate the above issue (Manual Tasks are not being generated in the Workspace) myself. Below are screen prints of what the Platform Monitor shows in my Environment Status -> Components tab.

And the same incident on my Environment Status -> Incidents tab.

Could you please advise as this impacts my further training.
Thank you in advance.