PU L1 - Assignment 3 - Using Data Store

Please use this tread for all of your questions of Power User - Level 1 - Assignment 3 - Using Data Store.

2.Double click on this Bot task -> Select a Use Case -> WorkFusion Training -> WF Set Data Store.

When I double click on the Bot Task - I see the Select a Use Case section, however there is no WorkFusion Training to select after that. vr1681

Two questions:

  1. In the assignment Instruction 5.1 requests that we download the attached file. however there is no link to or attached file to download?

  2. Previously we were required to submit the results of the assignment for grading, is that no longer required?

I am also unable to figure out where the attached file is.

@bbucholtz @john_soares

I’ve changed these assignments to RPA Express and added all necessary files to all assignments.
Please have a look and try!

How do we get to the RPA Express? I havn’t been given any links for how to get there.

@bbucholtz

First of all, you are welcome to the RPA Express course: https://automationacademy.com/learn/course/view.php?id=29
And you can download it here: https://www.workfusion.com/rpaexpress

Is there a way to do these assiments in the regular spa control tower and not via RPA express? I am not able to download rpa express until its certified at my company.

Hi @YShilyaev_Workfusion,
Thanks, but in my company we need to get authorization before we can install any software. So I am continuing with Control Tower.
While doing this and copying the previous process and adding a bot task as well as copying the earlier assignment’s attachments (data files for the data store - invoice_pic_rpax), I changed the respective values in the Bot Task for the data file name and column name as below:

<var-def name=“datastore_name”>invoice_pic_rpax
<var-def name=“datastore_url_column_name”>s3_invoice_link

When I run the process, it is stuck at the bot task because the bot task cannot find the relevant file. When I see the error, it says the below:

Failed to execute query:                
SELECT s3_invoice_link FROM "ds_invoice_pic_rpax"
           com.freedomoss.crowdcontrol.webharvest.plugin.datastore.exception.DataStoreProcessingException: Failed to execute query:                
SELECT s3_invoice_link FROM "ds_invoice_pic_rpax".

P.S: I have attached the exported the events excel file.

Please help.

events_2017-09-29 06-11-09.xlsx (4.4 KB)

@bbucholtz

If you have an access to the WF - you can proceed.

@parthasarathy_padhee

Did you close all of these tags by < / var >?
Did you created this Data Store before you launched the process?

Yes, I closed the tags. I just actually replaced the values. The code was given in the assignment.
The data store was created after the process was designed. But before it was launched (Run).

Hi @YShilyaev_Workfusion,
Please advise if you can help here. I am stuck at this position.

Hi @parthasarathy_padhee, @YShilyaev_Workfusion, All,

I have the same issue as @parthasarathy_padhee, was there any luck in resolving this?

Thanks,
Katya

Hi Kateryna, I didn’t find a solution to this still.

Will investigate it tomorrow on my win-laptop.

Hi,

I am trying the sample OCR process and data for PUL1 Assignment 2 and 3 on my local RPA Express instance.
For this process (as well as the Accounts Payable one available with RPA Express installation), when the process is run, it gets until the step where manual intervention is required through Workspace.
But beyond that, when I login into workspace, I don’t see the task entry there (or any error in the previous steps).

I have attached the screenshots for reference -
Process screen -


Workspace screen -

Kindly help.
Thanks - Krishna

Click on the ‘Tasks’ link in the top menu and find this task there.

Don’t see it there either.

BTW, I tried to reproduce the issue on my laptop - the process is working with the data from assignment.

May be the difference in RPAx version… Did you install the latest one?