Ran a newly created Business Process through "Publish as a Business Process". Nothing happens


#1

Hi
I have a RPAE project created using RPA Recorder. Everything works fine when I run it through RPA Recorder IDE by clicking "Play Recording"
But when I publish to Control Tower using “Publish as a Business Process”, it appears listed in “View All Business Processes” link in Control Tower.
However, when I choose “Run This Action”, nothing happens. It just gives a popup saying “Business Process successfully started”.

Where I am going wrong?


#2

Open BP in Control tower, that you tried to start, go to result
selct Bot task and click on blue “i” icon
copy errors you have there and attach here, please


#3

Hi
Please find attached exported CSV of the errors reported in above said procedure.events_2017-07-25 09-28-47.csv (35.5 KB)


#4

Find it where?


#5

I have attached it in my earlier reply. Please refer it.


#6

It says "Unknown button"
Can you show a screenshot of recording (from Recorder)?


#7

Hi
Please find attached PNG of the RPAE. CSV attached earlier also describes in full what is inside “Unknown Button” error which I am unable to understand.


#8

Do not see the whole script, but most probably, you have empty action somewhere - Enter Keystrokes


#9

No. It is not possible. It is success when I run it through Recorder IDE “Play Recording”


#10

As far as I could guess from long error log, it is something related to button clicks on Web Page which I am doing using “Web Element” action. I am using XPath to click a web page button.
Please see if it helps you to locate and fix the error.


#11

Then you are using an invalid Xpath
send me the webpage, xpath you are using, and show me somehow what are you trying to get

  • can you execute this script in recorder?

#12

Yes, script is getting executed in Recorder perfectly as I said earlier.
Also just now when I tried to use “Export to Groovy Script” feature given in RPA Recorder IDE, I got same “Unknown Button” error. I am attaching its screen shot. Please see if it helps.


#13

how can it be “executed in Recorder perfectly” if you are showing Execution error?
On which step it failed? please, show detailed screenshots


#14

How I am supposed to know that reason why it runs in Recorder and not in Control Tower. :slight_smile:
Again I am attaching one screen shot where I have shown web page being automated in FireFox (Which I am using to get XPath) and getting XPaths generated in FirePath Developer tool window as shown below


#15

So in above screen shot, when I want to click “Continue” button, I select “Mouse Click” Action from the RPA Actions library, choose “Click on Web Element (XPath)” option. And in the XPath field, I copy the path generated in XPath variable of FirePath developer tool shown above.

This whole process works perfect in Recorder IDE “Play Recording”


#16

try
//button[contains(@id, ‘SignIn’)]


#17

There are whole lot of web elements which I access and click. It will be a cumbersome task to fix every element like this. If it is running through IDE, it has to run through control tower. Else tell me How can I debug the script at run time?
When I open “Debug” perspective, I get below screen. I don’t know how to make use of it to debug my steps easily?


#18

But its not running through Recorder in your case
You showed me the error in recorder
https://forum.workfusion.com/uploads/default/original/2X/3/394b3b02a4fbe7cf439806725ce8cea645faa478.png


#19

No. It is not error of Recorder. When I choose “Export Code” => “Export Code to Groovy Script”, I got that error.

When I choose “Play Recording” option in Recorder, whole script runs perfectly.


#20

Send me recorderPlugin.log from
INSTALL_DIR\Workfusion\tomcat\logs