Random error in Clipboard from variable action since 1.1.5

clipboard

#1

Hi
I am getting a strange error: when copying a variable value to the clipboard the process SOMETIMES gives an error. Sometimes means I process for example 20 items of a loop and in the 21st the process stops with the error. The data structure of the variable that I move to the clipboard doesnt change. It is always a 9 digit string like: "B79321840"
I do exactly the same with the same variable content even in a step a few actions before and in that step the process never stops. Only in the one indicated.

Here is the detailed error message
Clipboard action error.txt (8.9 KB)

I use version 1.1.5 build 306. Same process did not show that error in 1.1.4.

Any idea anyone?
Thanks!


#2

Hi again
the error keeps coming randomly although I added now a clipboard-clear step before every clipboard action. Very annoying. Does that happen only to me?
Error executing ClipboardAction.docx (14.3 KB)


#3

I am facing issue in storing value in table variable. I have defined table variable as 5 rows and 6 columns. When I use copy from clipboard to variable option and print the table size, it shows table size of 1 row and 31 column. Even after using row and column separator the issue doesn’t resolve.

Here is the video link: https://drive.google.com/open?id=0B1muqlipTR4sVG9PYmNFQlowSnM


#4

@swati1,

please share your recording folder here


#5

@swati1,

You are using a wrong Row separator in the Clipboard action - should be LF.

please see this recording: win-r.zip (57.1 KB)


#6

hi swathi…


#7

Thanks. The issue got resolved.


#8

Hi Harini…


#9

hi swati,

I am stuck in few assignments in rpa developer…my gmail is harini1590@gmail.com.please guide me.


#10

Hi Harini,

Please let me know in which assignments you need help and I can provide you hints to do that. I suggest you state your doubts here so that others facing same problem can benefit from our discussion. We also have experts here to suggest best approaches to do the same.


#11

@swati1 @harmohan
Are you sure this is the right thread for your conversation?


#12

@harmohan is just going through and spamming all of the threads…


#13

@azinchuk I am facing an issue for a particular recorder variable… Is it not allowed for a variable to hold value that is a file location ? Error snapshot attached…

Recorder variables
image


#14

@timriewe Did your issue get resolved ? Did your clipboard action involve any variable with value as a file location ?


#15

do you use 1.1.6?


#16

It is Version 1.1.5


#17

@poorvi_dodwad
I resolved a similar issue as yours by using double slashes in the filepath variables. For example:
C:\\USERS\\file.xlsx


#18

@timriewe… Hey it worked with “\” … double back slashes… Thanks…
:grinning:


#19

:grinning::+1:


#20

Still getting this error with version 1.1.6.

I’m trying to access values in a list and the list is a row from an Excel table. I tried with the list below and it works.

cap20

But not with the row list that I really want to use (below). Is there a reason why it shouldn’t? The row has about 9 values in it.

cap21

Thanks.