Re-running a created business process

Hi, sorry I may have missed something. How do I re-run a completed business process?

I have observed that once I run a BP and is completed, when I go back to the run tab, the “Run This Process” button is gone.

Hi @Jerry_Guarino

you should copy the completed BP and run the new one.

@amashentsev

Is there a KB page where this information is described?

It’s in progress as a part Control Tower documentation. To be published asap.

@amashentsev
Is this a temporary workaround, limitation, or is it designed this way? When you are designing or debugging a BP you need to re-run it many times. Any plan of improving it in the future releases?

So now, I copied my simple BP, modified it, validated and saved without a problem. But the Run tab is disabled. The “Run Business Process” menu on the left pane is not working either.

1 Like

I had exactly the same question!

hope this could be enhanced

@Qi_Zhou_Singtel, @Jerry_Guarino

Please vote on the topic to help us prioritize.

@Jerry_Guarino

When copying your Business Process, select “Include the input data” option.

1 Like

Without the ability to run multiple times, how would we ever run a process on a schedule, daily for example, PLUS On-Demand when needed? Would we have to create a new process every day?

The ability to run a process repeatedly is kind of key for “Automation” is it not?

Please do let us know what the answer is to this question.

@Jim_Frost you don’t need to create a new process to run it on schedule. You just schedule one process to run daily, and each time the process runs a copy will be automatically created that will contain the information about this specific execution of the process and the result data.

You can see information about all process runs in the View All page of the Business Processes tab.

When you want to run a process manually, you don’t need to create a new business process, either. You should create a copy of the process and run it.

image

Thanks for the quick update Alesia

I assume we should think of the “Process” as what will be ran. Then think of the individual runs as “Runs”?

Naming them the same thing is slightly confusing to me, but I understand the concept now that you have explained it.

Thanks again!

2 Likes

Hi Alesia

Appreciate that you guys are very busy with the recent (magnificent) V2.0 release but it really would be great to get the documentation, or a webinar, or video , or indeed anything that would help understand the whole control tower and advanced features segment.

At this point I would happily pay for this…

Any update?

I wholeheartedly agree Bonnero! We need to get some documentation on the Control Tower in 2.0. I am using more a less a “poke and hope” approach to testing and it’s getting very frustrating.

I doubt we will be purchasing anything until we can see how to use it, and test the functionality we need.

In my case, I cannot do that either. It is coming disabled. Why?

Can someone tell … why is it coming disabled?

Hi @pbasubaul
Do you mean the Control Tower is unavailable?
I guess you have downloaded the Starter version of RPA Express from the website.

What version do you have?
You can look it up in Control Panel\All Control Panel Items\Programs and Features

Control Tower is available. I can stat the server, and it is showing to be running. For the Manual control is green. Now I have created the business process, and ran it once. It did fail for some reason, which I rectified and then when I tried to copy the process, it opened the copy dialogue box where the “Include the input Data”, which is a must for my bot to run, but here the checkbox is disabled. Why? what is wrong.

Thank you @pbasubaul

Does the pop up look like this?

Yes… absolutely…

If this option is disabled it means that you didn’t have input data in the process that you are copying.

You can check it from the Results tab
image

You can copy the BP and then upload the input data you need then.