Robot cannot click on a button, only selects it

The robot can click a button on a web page but it does not seem to click it for real.


It changes color but nothing happens.
It is possible that it is some kind of difference in authority?
I have tried a lot of different methods, like X-path and stuff.
It might be that it clicks but just nothing happens when the robot does it.

I got 99 steps that work but not the submit button at the end.

Strange thing is that I myself do not seem to be able to do it even manually in Chrome when the program pauses.

Might this have to do with the fact that the Chrome program has a status bar that says it is controlled by a Testprogram?

I can, of course, do this manually if I use regular Chrome.

Actually I now realize that the button is in a windows of its own.

What I done wrong is that I have opened a similar window by doing open “Web page” action whit the same URL, but even tough I can open a web page with the exact same URL and fill that page out, it is actually not the same page that the program wants to open.

This must be a common problem, if you are logged in to a web page, and that page opens up some other page.

I tried to include the URL, in front of the x-path but of course it did not work. I have very rudimentary knowledge about how buttons work on web pages. At least it does not seam to be contained in a “iframe”.

The program should follow trough to the new page that is opened but it does not.

Hi @michael_larsso so the new URL is opened in a new window, correct?

Exactly but at my first try I did not push the button.

I used a web action because the URL is the same.

Then I seam to have enter some kind of shadow page where everything operates the same way until I try to save then it does not work.

That confused me a lot.

I would like Chrome to follow to the new page, so that my x-path will work normaly.

If a new URL is opened in a new window or in a new tab, the focus of the bot stays on the previous window (tab), but you can switch to the new one using one of the custom scripts in this topic

I hope it helps you!
Let me know if it doesn’t.

1 Like

Amazing works perfectly on the first try.

Thanks I have been working with this for 6 h.

1 Like

Glad I could help :slightly_smiling_face: