RPA 2.0 major outage, not working properly

I’m not sure what has happened, My IT have Installed RPA2.0 on my PC while I was away. Because of this there appear to be some issues. Studio appears to work as well as 1 bot (not 9) there is a message in Platform manager of major outage.
Can you explain how to resolve the following please:
The other 8 bots ask for a password, I don’t believe this was set, how do I reset / update the password to activate these bots?

I am currently having issues with the Studio and it is not recording the cell information from a spreadsheet I have requested. I haven’t done anything different and I know under 1.2 the process worked fine.

Looking at Platform Manager Components there is alot of Red (see below) how do I resolve this?

image

I’m pretty certain something wasn’t loaded properly, any way to confirm what it was.

FYI to install RPA, I have to have the PC reimaged and made from scratch. Suggestions before I go back to my IT would be appreciated.

Jason

Hi Jason,

We had this issue in 2.0.0 when remote bots asked for a password. It has been fixed for version 2.0.1, so you will need to update to a newer version.

The Major outage status doesn’t in itself mean that there is an issue. It can just mean that the component hasn’t been started yet. You can start all the components from the tray menu and recheck the statuses in Platform Monitor (it might take up to 10min for all of them to update).

As for this issue

How do you record the cell information from the Excel file, by using Excel action or by opening the file and using images/keystrokes to copy the information?

Thanks for the help as always

I have been using the Excel action to copy the information to a variable. And then try to copy that variable into JD Edwards program. This has worked fine in the past, but not at the moment. I also tested it by copying the information to notepad as a test. with the same lack of success.

This is weird, since we didn’t change Excel actions at all in this release. Could you share your script or screenshots of the actions, so we will try to reproduce this issue?

This is the basic action to get account number from Excel spreadsheet and save to String Var. The bot can manipulate the screen, but it won’t actually enter the Var. value into the specific field. I’ve tested this the other way as well, so both images and excel action have the same issue.

Screenshot of program
image

Screenshot of JDE screen (trying to put account Var into Parent field)

Is the cell value recorded in the execution-result.log?

I would expect so (haven’t checked) I ran a test and pasted the Var to Notepad. I have been thinking about it, and will need to check with the IT (for both companies to see if there have been any security updates lately that could effect this).

Hi there

I check with both IT departments and they confirmed that there doesn’t appear to be any updates that could have an effect like I mentioned.

And yea the value is recorded in execution-result.log.

image

Any more thoughts?

It might be related to the keystrokes action being faster now.
Is it possible that the window in which you type the data doesn’t have time to load before the data is inserted?
Try adding a bigger timeout to the keystrokes action.

Hi Jason, did you have a chance to do these changes? Did it help?

Tried it, but didn’t help. Sorry. The interesting thing is there is another Oracle program I tested a bot on and it worked fine so not to sure. Currently unable to use xpaths either but I don’t think that is the issue. I’ll keep you in the loop

1 Like

Thank for update Jason. We’ll try to test it from our side.

Jason, your issue seems to be related to this problem with remote desktops Workfusion 2.0.1 - Removes spaces in string on RDC
We are investigating it now.

Interesting, thanks for bringing it to my attention. But the issue is with any data been “typed” in mostly account numbers like 12345. So even if there was a spacing issue it would still be inputting the info.