RPA Autoit driver logic stopped working

rpa
jvm

#1

Due to automatic java update Autoit driver may suddenly stop picking up controls off a java application or applet. If this is the case you’re facing, please make sure the java version used by the RPA Agent and the java application you are working with are started by the same java and their corresponding JVMs will be of the same version.

The easiest way to check which Java is used by default on a computer - is to use Java Control Panel. From there, navigate to Java tab, then click View button, then make sure that only one, and identical, JRE is selected on the System and User tabs.

When the path to system Java is determined, the same path has to be set for the JAVA_HOME variable in your start_rpa_node.bat file

...
set JAVA_HOME=E:/work/Java/jdk1.8.0_91
cd %~dp0 
%JAVA_HOME%\java -Dfile.encoding=UTF-8 -Dlogback.configurationFile=logback-node0.xml -cp      %JAVA_HOME%\lib\tools.jar;*;dependency\* com.workfusion.grid.CustomGridLauncher -role node -nodeConfig .\node0.json
...

To troubleshoot java applet it may also help to enable console logging and tracing


#2

This solution worked for when trying to initiate autoit on java applet. IDE prompted error when looking for the element but after applying the above settings then autoit found the CLASS.


#3

You may also check RPA JVMInspector not seeing other processes if that is the looks like the reason for RPA not working