RPA Express 1.1.5 issues

@sanjeev_sapre
the version with the fix has been released. you can download and install the new version.

1 Like

Hi

I have downloaded the 1.1.5 and found that switch window is not working as expected, recording got stuck at it, no error nothing is happening after it.

Also after publishing it on control tower, switch window is taking so long to respond.

for 1.1.4 this issue was not there.

Regards
Pramod sadhav

Just an observation…

My recordings are not working fine as it did in 1.1.4. The recording simply hung up and i have to restart rpa express. Again it hung up at some other step.

After updating from version 1.1.4 to 1.1.5, When adding a click_event for a single click on a coordinate or a dragging of 2 different sets of coordinates, The Coordinates seem to be adjusted automatically with no ability to overwrite them. If I set a click event on coordinates 820 x 415, the code would show 820 x 820.

Hi there,
Since an upgrade to 1.1.5, I have a use regarding a Excel command in a Loops…
I run a script over 10 times the same excel command (set active cell to start of the document) and it work. But if I use this command in a Loops command (while, repeat) it will work one time and stop after. The stop is a hard stop, the robot is not responding……

I script was working without any issue before (1.1.4).

I will like to know, where the problem, me or the new version is.

Regards,

Stéphane

I’ve also notice similar issues with RPA 1.1.5 whereby recordings that executed without hiccup on 1.1.4 now hang and I have to routinely restart RPA express. It hangs on random steps so I cannot isolate a fault with the recording.

How can I downgrade to 1.1.4 as I get compatibility issues with recordings that have been opened or created in 1.1.5?

Regards,
Omkar

I too agree with @stephane_wagner and @omkarb there are lot of such issues in version 1.1.5. The scripts which used to work perfectly fine in version 1.1.4 are now giving weird issues such as recording play hangs without giving error and if you try to stop the recorder it gives no response – eventually one has to hard stop RPA express and restart Bot Manager.

Here are 2 more issues for your references with version 1.1.5:

https://forum.workfusion.com/t/version-1-1-5-keyboardaction-execution-error-with-single-backslash-character/11289?u=amit_khurana

2 Likes

Dear all,

RPA Express Development team is working on the release with fixes of the issues. As soon as the release is available for download, we will notify you in the forum. Stay tuned.

CC @amit_khurana, @stephane_wagner, @omkarb, @jeremy_elgas

7 Likes

Team,

Another issue which was not in version 1.1.4 but has been observed in version 1.1.5.

If “Enter keystrokes” option has “Type text” value with “back slash” character as a part of content, it results in following error:


Caused by: org.codehaus.groovy.control.MultipleCompilationErrorsException: startup failed:
Script3.groovy: 2: unexpected char: ‘’ @ line 2, column 21.
sendKeys("C:\ParentFolder\ChildFolder\image1.jpeg ");

Please refer attached image and error log for reference:

Error Log:
KeyboardAction_ErrorLog.txt (4.0 KB)

Workaround: Replace “single backslash character” with either “double backslash character” or “single front slash character”.

Workfusion team, please look into the issue!

Regards!

1 Like

@amit_khurana
thanks for posting the workaround. Development team is looking for solution.

2 Likes

with so many issues in 1.1.5 and OCR licenses expired in 1.1.4 and all previous versions, I am totally stuck!

1 Like

@amashentsev could yon extend the OCR licenses validity since there is already a 10K limit on it? at least normal user as me can still use the current version.

is there an expected timeline for the fixes?

now we can use old version due to OCR issue and the new version is not usable for old scripts and with so many issues! though this is a free product, i think a MVP still needs to be there!

I am also facing issues with loop on 1.1.5. I have not done extensive testing but it looks like the nested while somehow hangs.

1 Like

Trying to run my process in 1.1.5 it stops (freezes) randomly in different steps every second time I execute it. Then I need to force-close RPAx and launch it again.

After closing I get this message:

image

The same process ran fine in 1.1.4

@timriewe Yes this is another issue and same experience at my end as well.

Hope the next release has the fix for this issue too, as specified by @amashentsev in the following post:

@timriewe

the problem with Recorder hangup is solved in the new release of 1.1.5. Please update your version.

Hi @amashentsev, thank you for the update! I have executed a few of my recordings and can confirm that the hangup error has been resolved.

1 Like

I also have a similar issue. I have a script which used to work properly in 1.1.4. I have a “Replace Text Action” replacing “$” with “$” before I insert the text into an Excel cell. This action worked with the previous version with no problem.

Now, I’m getting errors about escaping the dollar sign. I have also tried using “$”, but then it adds another backslash to it and gives the same error.

Any guidance is highly appreciated.

@payam_bahreyni Well as a workaround, you can use following approach:

While using “Replace Text” operation use variables instead of the direct text ($) i.e you can use something like this:
In “Text to find” option: ${search_text_variable}
In “Replace with” option: ${replace_text_variable}

Where ${search_text_variable} = “$” and ${replace_text_variable} = “$”

This will enables the values with “$” as a character in it, to be successfully saved in Excel Cell Values.

Regards!

Hi

In for each loop not able to fetch item

can anyone help