RPA Express 2.2 is released!

release

#1

Hi Everyone,

We have released new RPA Express 2.2.

Here are the most important new feature and improvements in the new version.

Please leave your feedback and questions about the release in the thread below!

NEW FEATURES

Excel

  • Excel actions (Get cell value, Get column, Get row, Get range) work with values calculated with formulas.
  • You can set numeric values in Excel in Number format.
  • Long number values in Excel are parsed in Big Decimal format instead of Scientific one.

Inspector

  • Generation of selectors in Outlook, Excel, SwingSet, Total Commander, cmd, Start menu and other Windows applications has been improved
  • Inspector supports 2 types of selectors:
    • CSS selectors (default)
    • Object selectors
  • Inspector allows to see and switch back and forth between all elements that correspond to a selector
  • If you need to have Admin access to the application to inspect it, you will see an appropriate message

IMPROVEMENTS

  • Numeric values (both in Text and Number format) are copied from Excel without .0
  • When selecting a variable in a dropdown menu, the type of variable is shown
  • Disabled actions have been removed from the Actions Library

BUG FIXES

  • Business process execution fails in Control Tower if the same Secret variable is used in several bot tasks - Forum topic
  • Double click on web element doesn’t work - Forum topic
  • Right click on web element doesn’t work - Forum topic
  • OCR service hangs and needs to be restarted - Forum topic
  • Enter Keystrokes action adds redundant keys - Forum topic
  • When comparing decimal numbers, the decimal part is ignored - Forum topic
  • Changing Anchor region in a copied Mouse click action changes it in the original action - Forum topic
  • Web actions cannot be dragged under some Loop actions - Forum topic

See details in the Release Notes.

This version of RPA Express is compatible with SPA 9.2.

Best regards,

RPA Express Team


Retrieving multiple reports from a website with inputs from a file
Single click works but not Double click
Excel formulas values not working with get cell function
Left click on the xpath element works fine but not the right click
Copied action Mouse Click changes the anchor of both actions
RPA recognized Excel number as text
Secrets vault variable issue when running BP that contains two Bot tasks -RPA v.2.1.1
Keystrokes error in 2.1.0
OCR action fails in RPA Express V2.0.5
#3

Hi!

Do you recommend this version if we have SPA 9.1 installed?

Thanks


#4

@drew_a_fator with SPA 9.1, you should use RPA Express 2.1.3

https://kb.workfusion.com/#expand-CheckRPAExpresscompatibilitywithWorkFusionSPA


#5

A post was split to a new topic: Keystrokes fail in Excel


#6

HI
I got an error in updating from ver2.1 beta to ver2.2.
Sorry I could not copy the error screen.
Perhaps an error occurred around the updating of WORKSPACE,
and asked whether to try again from the installer.
When I answered that I did not try again, the installation rolled back and stopped with an error.
Currently Ver. 2.1 is in operation.
Should I install ver 2.2 after uninstalling ver2.1 beta without updating?


#7

@tamotsu_itoieq yes, you can uninstall 2.1 and install 2.2. But if you have any business processes in Control Tower, create a backup before you uninstall the current version.

https://kb.workfusion.com/display/RPAe/How+to+Run+a+Business+Process#HowtoRunaBusinessProcess-Businessprocessesbackup


#8

Hi ashapkina
Thank you for your answer.
After uninstalling Ver 2.1, I installed Ver 2.2 successfully.


#9

Glad I could help :slightly_smiling_face:


#10

Good day

I want to find out if i am the only person experiencing this problem.
I’ve installed 2.2 and now my bots are failing on a odd location.

for example is i want my bot to type in a email. i would go CTR + n for a new email.
and then prompt typing, but the new window falls away and bot types in the mail box and opens mails.
this is also happening when bot opens excel and clicks browse and needs to type a file location.

this worked perfectly before the update.


#11

@ivan.swiegers perhaps, the bot starts typing before the window is defined. Do you have a Switch to window action (switching to New email, etc) before typing?


#12

Ive tested this now and it can work. but I had to struggle with it.
it took 4 window function switches to just send out an email will an attachment.

is there a way to role back a workfusion version? this is adding way too many steps for me and ive had to revert to image clicks.


#13

Untitled


#14

Hi Ivan,

Try to edit the sample version provided by Workfusion it normally works or just use on click with an image of the button.

Best regards,
Michael


#16

@ivan.swiegers you can download and install verison 2.1.3 from the KB https://kb.workfusion.com/#expand-CheckRPAExpresscompatibilitywithWorkFusionSPA
but note that there might be migration issue when going to a previous version.


#17

I’m also noticing that clipboard actions are a lot slower in the new version


#18

Here’s another flag-

Occasionally when trying to add a window action, all I get is a loading screen:


#19

This is apparently an antivirus issue, solved.


#20

Yep, this typically happens when your antivirus blocks our MFWDesktopUI.DLL

Now we are improving the digital signature mechanism + this file will not be unpacked each time you run studio.

So in the 2.3 release this problem should go away! :space_invader: