RPA Express and Mouse Click Action (image)


#1

Hello,

Running RPA Express Recorder 1.1.8-beta and when playing a recording that has about 40 steps, it fails on step 30 that involves clicking on a web drop down selection. The errors are:

Error executing MouseClickAction…
Caused by: org.openqa.selenium.WebDriverException: Image does not found : 1513265263209-anchor-1513265278486.apng
Caused by: java.util.NoSuchElementException: Image does not found : 1513265263209-anchor-1513265278486.apng

The mouse click on the image has been retaken several times but this step always fails and I also have a 10sec timeout. All screen captures were made from the portable Chrome browser as part of the install.

I have other mouse click actions prior to this step that work fine.

Any ideas what could be causing this please?

Thank you.


#2

Does your image capture area has any dynamic content? Or Does the image change from previous actions? Does the size of the screen during capture and execution same? Please check these.


#3

@shajad_ashrafl,

need your recording to help you solve the issue


#4

Yheah I’ve recopied the image from the web page using the same screen size multiple times but still no change. Basically it’s drop down field on the web page that has a default setting but once the drop down is selected you have two further choices and selecting either creates an additional set of options. Never gets this far just errors as above.

On a side note, if you have a website url and to this you wan’t to append a numeric ID for a user (eg. http://intranet.abc.com/application/UserID=xxxxxx), how would you achieve this using the variable listing? So copying the id from a notepad that contains a list of UserID’s and for each user the url above you changes the UserID=xxxxxx. Any thoughts on this please?


#5

@shajad_ashrafl

Hi Shajad,

As far as your second question is concerned, you can store the static and dynamic parts of the url in string variables, and use Join Strings action to form the final url, as shown in the sample recording attached.
join-strings.zip (6.8 KB)

As for the issue with mouse click action, could you post your recording here so we could have a look?

Alesia


#6

Hello,

Thank you for your replys. Regarding the mouse click action, I attach the zipped project. The failure occurs on steps 7-8 whether or not I have the Move Mouse action (clicking on an image titled ‘This item & Sub-items’). I have even replaced the image using the recorder action but still no success.

I am using the supplied Chrome Portable for all actions with no resizing of windows.

Thank you.recording-1515435317244.7z (22.1 KB)


#7

@shajad_ashrafl Is the menu item blue only when you hover on it?


#8

Hello Ashapkina,

Yes the menu options are Dark Blue as per attached jpg with screen shots when hovered over but go white once selected.

Regards,


#9

@shajad_ashrafl
Try capturing the image of the menu items when they are white (not hovered over). Does the action work in this case?
anchor


#10

@shajad_ashrafl Did changing the image work?


#11

Yes - thanks that worked. I captured the screen without highlighting.
When playing back it works most of the time but occasionally it fails. I’ve tried adding a 1 sec wait but that doesn’t look to have fixed the issue and then increased this to 5 secs without change. I then recaptured the image again and still running it through, say 5 times, it fails 1.


#12

@shajad_ashrafl
Does it always fail at the same step or at different steps?
Please share the error details.


#13

Hello,

It fails on the same or the next step - always. Pretty much one or the other.

Changed the screen captures, retry, wait m/secs etc. but still the same outcome.

Regards,


#14

@shajad_ashrafl
Could you share the recording or screenshots of the actions that fail?
Thank you.