RPA recorder fails to register keystrokes


#1

Hi,

I am recording against notepad.exe on Windows 7 x64 and experiencing issues with keyboard events not being recorded.

Steps:

From RPA Recorder I do:

  • Hit CTRL+6 t start the recording
  • Click OK to use the default script name
  • Hit Win+R to open the Run dialog
  • Type notepad.exe into the Run dialog
  • Hit ENTER to run notepad.exe
  • Type test into Notepad
  • Hit ALT+F4 to close Notepad
  • Click on [Don’t save] button to ignore the changes

What I get:

  • Window (Run)
    – Enter Keystrokes (ENTER)
  • Windows (Untitled - Notepad)
    – Enter Keystrokes (Alt+{F4})
  • Windows (Notepad)
    – Click Mouse (click left button)

In other words, Win+R was not registered; neither were the keystrokes for t, e, s and t.

RPA Express RecorderVersion Details:

  • Version 1.1.5
  • WorkFusion RPA Express
  • Sunbird

RPAx Recording Trouble
#2

please post here your pc full spec and a video of your recording process. Thanks


#3

hi @azinchuk:

PC full specs? Not sure what you need to know: it’s a Lenovo t450 with 8 GB RAM, an Intel i5 and a SSD running Windows 7 Professional. Do you need to know anything specific?
You other request is less easy to answer, because I already uninstalled RPAExpress. I don’t think I do anything specific though. See the steps I wrote down, they should give you an idea.
And BTW, I searched for similar issues yesterday and found RPAx Recording Trouble. Maybe there’s more, but I just stopped my search with this one issue.

Also, I could replay some of the examples, from Recorder and from Control Tower, including some where keystrokes were involved (but I don’t remember which ones). I remember the playback of keystrokes was painfully slow.

I am not sure how I’m supposed to add attachment. I dragged-and-dropped the zipped recording. There should be an anchor tag below.

recording-1506421421612.zip (398.6 KB)

Other issues:

  • screenshots are made of the pause/stop toolbar
  • IE crashes on playback witth: Caused by: org.openqa.selenium.WebDriverException: Unexpected error launching Internet Explorer. Protected Mode settings are not the same for all zones. Enable Protected Mode must be set to the same value (enabled or disabled) for all zones. (WARNING: The server did not provide any stacktrace information)
  • the XPath plugin for Chrome crashes
  • generally slow
  • too much noise being recorded (mouse drags, etc.)
  • the amount of resources! You recommend 8 GB, but I would say 16 GB. With 8 GB I cannot do much. Actually using some tool I found in the installed file it seems that RPA Express runs three JVMs, one needs 4,6 GB, the other 1,6 GB and the last 1 GB = 7,2 GB. That’s why I think that 16 GB (or 12 GB) is recommended.

#4

It hapens to me to, but when I put the text in a variable it worked fine.
It takes a bit longer to write on screen, but it worked as a workaround.


#5