RPA Recorder XPath issue


#1

When I am trying to run my recorder to capture the xpath of a website
It works for the first group but the subsequent failed. but no error message shown.

Refer to the video recorded. Thanks.


#2

@rene_naidas - this video is not available

please post a valid link and also share your zipped recording folder here. Thanks


#3

Hi,

It’s a youtube link. Refer to my attachment for reference.


#4

please make a simple script which reproduces your issue - just browser navigating part


#5

Hi Azi,

Attached is my file.

  1. Eventhough I tried to make sure the xpath for the 2nd results still entering the same value from the first xpath.

  2. after entering second product list it wont enter to the sheet anymore the capture results


#6

@rene_naidas

This happens because different products have different badges (link or span web elements). See:


#7

Hi,

So does it mean I will not be able to capture this? Please help how I can handle this part.


#8

Test_Practice_2.7z (29.1 KB)

Here is a working sample. There was also another issue there - some products had original price, and some - not

So these cases are solved using Error Handling block.

General advice: Before automating a case, you should analyze all possible variants.


#9

Thanks for the help.


#10

Hi Azinchuk,

Kindly let me know how can I get some notes relating to XPATH.


#11

Hi,

I need some help here.
First search results can be saved inside a variable and enter to a worksheet but the second
search result will show an error message. please refer to my attached project.

thanks

Test_Practice_3.zip (70.9 KB)


#12

@rene_naidas - I guess you have the same issue - not universal XPAth like

//*[@id="CatalogEntryProdImg_100518"]/span[2]

This id attribute is dynamic (unique for some product), so you need to change it to something like

//*[@class="pr_nlst_wrp"][1]//span[2]
//*[@class="pr_nlst_wrp"][2]//span[2]
//*[@class="pr_nlst_wrp"][3]//span[2]

and in a loop it can be used like this:

//*[@class="pr_nlst_wrp"][${counter}]//span[2]

See our new XPath guide which will help you create reliable XPaths:
https://kb.workfusion.com/display/RPAe/Quick+XPath+Guide


#13

Get more information regarding XPath in RPA Express here:


#14

Hi,

It doesn’t worked for me. The value still the same especially the product name. I am trying to do a mouse click to go to the site then do an xpath but the mouse coordinates doesn’t work for me.


#15

I am trying to click each results by doing the muse click coordinates but it is not working. Any other way to click the link to go to the product screen. Thanks.