Rpae scheduler not working


#1

The scheduler is not working it shows status pending even if the schedule starts

Also when we click start nothing happens it shows pending


#2

Have you reset the settings?


#3

@ruchita_desai - please provide more details - your schedule screenshot, etc


#4

Attaching Print screens regarding scheduler and log files.

Please tell me if any more action /log required from our side.
We want to run a job on time(only one time in 24 hrs.)


#5

error.log (605 Bytes)
access.log (6.6 MB)
rpa-node0-2017-12-05.0.log (9.6 MB)


#6

Hi, according to your server time, its 12.35 am and your schedule is due for 12.33 pm. So technically, for the next 12 hours, your schedule will be in pending status only. Your schedule will work perfectly if you align your schedule time with server time.


#7

No sir, it’s 12:35 pm only(server time) we tried to schedule with different timing also still job is not running. If we schedule for every minutes / hours then it is executing successfully, but we want it to be run only once in a day time
!

Also find print screen for different time (12 hours difference)


#8

@ruchita_desai - your last screen shows that the Schedule is set to 1:19 AM each working day.

And your server time at that moment is 1:20 PM

So you need to wait 11 hours 59 minutes.


#9

I have the same problem, but the process wont trigger. We tested it with a “every 30 min” schedule. There it started as expected, but after we changed the schedule for “at one day of the week at a specific time” nothing happened. The status was on “pending” the whole time. We also tested the process manually to check if it works as intended and everything worked fine…


#10

I can get it to trigger at a correct time, however, I had to set it to a 4 hour offset for it to trigger at the correct time. Instead of 8am, I start at noon and it triggers at the right time.


#11

@eduard_wilhelm @jdoering,

Thanks for pointing out this issue - the Scheduler currently starts all processes according to GMT time (not the server time). We will investigate and fix it.


#12

Hi all, I have publish my recording to Control Tower. From Control Tower, I schedule my business process at certain period (Every 30 minutes). However, it seems that my schedular is not working properly as the status of schedule is always PENDING
Is there any missed out from me or this is limitation for free RPA tools for scheduling features, thanks.


#13

@jhleeEaYlfrscY

Hi Jian Hao, the reason might be that Scheduler currently starts all business processes according to GMT time. We are already working on this issue.
The process might still have status Pending as the schedule period you specified hasn’t started in the GMT timezone.

Alesia


#14

Hi @ashapkina, thanks for replied. However, since yesterday till today, the schedule job status still in pending status. Therefore I wonder am I missed out any steps when create schedule job or is there any special step I need to do for it.

Thanks.


#15

@jhleeEaYlfrscY

Could you please send the screenshot of your schedule for the process?


#16

Hi @ashapkina

The screenshot as below

I have been schedule since wednesday and it is not functioned for wed and thurs as I schedule on these two days.
Is there any steps I missed out?

Thanks.


#17

@jhleeEaYlfrscY
Hi Jian Hao, sorry for a late reply. According to your settings, the process should have triggered during the schedule period. Are you sure the Control Tower was working during this period?


#18

@jhleeEaYlfrscY Also, does the process work when you start it manually?


#19

Hi,

If i schedule BP to start every hour or 10 minutes past the hour, they start.

But if make schedule on every working days at 10am and 15pm, they doesn’t start. I tried to copy BP and schedule the copied one. I tried to schedule task instead BP, but not starting.

Any idea what might be a problem?

-mikko


#20

@mikkoVKXBiWReM
HI Mikko,
The reason is most probably the fact that Control Tower now starts all processes according to GMT.
It is a known issue with Control Tower. The only workaround now is to change the start time according to GMT time.