Sample business processes from Control Tower not working

I’m trying to run sample business processes in Control Tower (License Verification, Criminal Records) but they fail when starting Firefox (the window opens, but it fails to enter URL). Below sample from error messages I see in the logs. Have you seen these issues? Is there a solution or troubleshooting guide I can use?

Step name ‘Get License’ has failed. Reason: ‘[urn:uuid:CE6AF15F8F84D944BD15293221378944] robotics-flow executePlugin exception: [nodeId=http://127.0.0.1:1] org.openqa.selenium.WebDriverException: Error forwarding the new session Request timed out waiting for a node to become available. Command duration or timeout: 300.31 seconds Build info: version: ‘9.0.0.3’, revision: ‘1610cb545e’, time: ‘2018-05-24T16:45:36.185Z’ System info: host: ‘PF0FK6LZ-X7’, ip: ‘143.28.41.194’, os.name: ‘Windows 7’, os.arch: ‘amd64’, os.version: ‘6.1’, java.version: ‘1.8.0_121’ Driver info: driver.version: RemoteWebDriver’

Step name ‘Get License’ has failed. Reason: ‘[urn:uuid:CE6AF15F8F84D944BD152932323732226] robotics-flow executePlugin exception: [nodeId=null] Connect to 127.0.0.1:15444 [/127.0.0.1] failed: Connection refused: connect’

Hi Dariusz, can you export the full event logs for both processes to Excel and post here?

Hi @ashapkina thanks for a quick response. See attached logs from the license verificaiton process. “Check criminal records” process gets stuck after opening the firefox window without generating any logs or making progress.

Thanks, Darekevents_root_2b1b0c45-657c-4947-9797-e9c6ae1c3fd7_2018-06-20 02_08_51.xlsx (9.1 KB)
events_root_347b7223-27ce-4a89-8384-421a74ed9521_2018-06-20 02_08_34.xlsx (6.3 KB)

There seems to be a problem with the nodes.
How many bots did you select when you installed RPA Express?
Also, please zip and post here these logs C:\RPAExpress\RPA\logs

Attached zipped logs. I don’t remember exactly how many bots I selected (where can I check?), I assume I applied the default settings. Thanks again for helping!
logs.zip (278.9 KB)

I also found out now that when using RPA Express recorder (rather than Control Tower), Web actions with Firefox are not working, but they work ok with Chrome. So this issue might be browser specific related to Firefox.

Hi, @kleczek.d
can you, please:

  1. Stop Bot manager
  2. Remove all logs from INSTALL_DIR/RPA/Logs
  3. Start bot Manager
  4. Run BP (From Control Tower)
  5. Share results (Logs from the same destination + event logs from Business process)

Hi @mzhalniarkevich, attached the logs per instruction. Note I stopped the process after a few minutes of inactivity (it got stuck after opening firefox in incognito mode).

Thanks! DarekWF_logs_error.zip (7.9 KB)

I managed to edit the script and replace the firefox driver with chrome - it worked. So the issue was related to firefox driver.

1 Like