Schedule Frequency shows different days than selected

I am trying to set the scheduler in control tower to run Monday through Friday from 7am - 7:30pm PST. So, I calculated what that would be in GMT and I figured the best way to do it would be to set 3 schedules as follows…

  1. Minute - On The - 0,30
    Hour - On The - 0,1,2,14,15,16,17,18,19,20,21,22,23
    Day of the week - Tue, Wed, Thu, Fri

  2. Minute - On the - 0,30
    Hour - 14,15,16,17,18,19,20,21,22,23
    Day of the week - Mon

  3. Minute - On the - 0,30
    Hour - 0,1,2
    Day of the week - Saturday

But for some reason when I select Tue, Wed, Thu, Fri in the GUI “Create Cron Schedule” pop-up and click save schedule then in the schedule frequency it says “on Wednesday, Thursday, Friday, and Saturday”. Why doesn’t it say the days I actually selected? Which days will it run on? The days I selected or the days it says. This doesn’t make sense, is this a bug?

Hello @lambsivy,

Is it possible to provide screenshot of your schedule?

Sure. Here is a screenshot. You can see that the pop-up shows Tue, Wed, Thu, Fri, yet the screen behind says Wed, Thur, Fri, Sat. This is an example of #1 from my original post.

Also… Do you know if there is any way to turn off the password request for the secure storage upon the app starting up? I added Workfusion to the startup apps for window two ensure it runs automatically even if the computer restarts but it always prompts for the password during startup which means it won’t start running until I enter the password. I just want to ensure the scheduler is always running even if the computer is restarted. Thanks.

Hello @lambsivy,

Which timezone is on your PC? I see that difference between PC time and Control Tower is 7 hours. So this can be the issue with scheduler. Did you try to move “Day” to 1 day earlier?

As about auto-launch, you may refer to this article - https://doc.workfusion.com/express/docs/iac-express/core/configure-auto-launch/.

I am in PST, so yes 7 hours currently is the difference. But which day is the actual day that it will run? The ones I select in the pop-up or the days it says on the scheduler?

The strange thing is that Tuesday at 0:00 my time is still Tuesday in GMT, yet it only says Wednesday on the screen after I select Tuesday. So, Are you suggesting I select Monday if I want it to actually run on Tuesday? I get that My time Monday evening will actually have be the end of the day Tuesday in GMT. So I would assume the results would show Tuesday and Wednesday in that case or if only one day it would show Tuesday since that is the start and more hours fall into Tuesday but it appears it only shows Wednesday so I am very confused. Given that I am 7 hours behind GMT and I want this scheduler to run Tues, Wed, Thu, Fri from 7am - 7:30pm what would I select for Days of the Week. I think if you let me know this then I can figure out the rest on my own. Thanks.