Scripts not migrated to v 1.1.1


#1

I downloaded RPAex 1.1.1 today, but the scripts made with version 1.1.0 can’t be used with the new version as automatic migration did not work. I hope that in the future scripts can be migrated to new versions.

The error message when I try to open an old script says:“This file was created with an older program version and automated migration failed. Model does not contain namespace URI”


Recording is not playing
Version 1.1.8 RPAE file Conversion Error
Migrate lower version workflow to higher version
WF RPA 112 - OCR no more working
RPA Express version 1.1.1 is rolled out
Migrate lower version workflow to higher version
#2

Hello, @bjorn.kvisli. Can show us your script file?


#3

It is just a small script I played with a few weeks ago. I can’t remember what it did. I have the same problem with other scripts from v 1.1.0

<?xml version="1.0" encoding="UTF-8"?>
<recorder:ActionFlow xmi:version="2.0" xmlns:xmi="http://www.omg.org/XMI" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xmlns:recorder="http://www.workfusion.com/recorder/v1.0.0" ignoreDelays="false">
  <actions xsi:type="recorder:OpenURLAction" active="true" actionDetails="(https://oslobors.no)" delay="0" url="https://oslobors.no" waitTimeout="5000">
    <actions xsi:type="recorder:WebElementAction" active="true" actionDetails="(get by //*[@id=&quot;most_traded_osloaxes&quot;]/table/tbody xpath)" delay="0" varName="variable0" varType="[[Ljava.lang.String;" xPath="//*[@id=&quot;most_traded_osloaxes&quot;]/table/tbody"/>
  </actions>
  <actions xsi:type="recorder:OcrAction" active="false" actionDetails="(to 'null' rectangle 109 x 13)" delay="0" offsetX="109" offsetY="13" awaitTimeout="5000" pollingInterval="300" imageName="1494928374502-anchor.apng" fullImageName="1494928374506.png" width="78" height="14"/>
  <actions xsi:type="recorder:LaunchAppAction" active="false" actionDetails="(&quot;C:\RPAExpress\Appli...; wait for 0ms; poll every 0ms)" delay="0" command="&quot;C:\RPAExpress\Applications\FirefoxPortable\FirefoxPortable.exe&quot; oslobors.no" autoDetectWindow="true"/>
  <actions xsi:type="recorder:MouseClickAction" active="false" actionDetails="(click right button)" delay="0" offsetX="-52" offsetY="28" imageName="1494937457564-anchor.apng" fullImageName="Uten navn2.png" button="2"/>
  <actions xsi:type="recorder:MouseClickAction" active="false" actionDetails="(click right button)" delay="0" awaitTimeout="1000" pollingInterval="10" imageName="1494937777079-anchor.apng" fullImageName="Uten navn1.png" button="2"/>
  <actions xsi:type="recorder:MouseClickAction" active="false" actionDetails="(click right button)" delay="0" offsetX="13" offsetY="1" imageName="1494937249357-anchor.apng" fullImageName="Uten navn1.png" button="2"/>
  <actions xsi:type="recorder:KeyboardAction" active="false" actionDetails="(Ctrl+v)" delay="2000" modifiers="2" paramString="NATIVE_KEY_TYPED,keyCode=0,keyText=Undefined,keyChar='v',modifiers=Ctrl,keyLocation=KEY_LOCATION_UNKNOWN,rawCode=86" text="v" rawCode="86" keyChar="118" type="HOT_KEY_PRESS"/>
  <actions xsi:type="recorder:RandomValueAction" active="false" actionDetails="(to 'variable') - String" delay="0" varName="variable" varType="java.lang.String">
    <stringRandomProvider length="20"/>
    <numberRandomProvider min="0" max="100"/>
    <dateRandomProvider fromDateTime="1494939245385" toDateTime="1494939245392"/>
    <listRandomProvider length="10"/>
    <tableRandomProvider rowsNum="5" columnsNum="10"/>
  </actions>
  <actions xsi:type="recorder:ClipboardAction" active="false" actionDetails="(to 'variable')" delay="0" varName="variable" varType="java.lang.String" activeConversion="STRING_TO_STRING">
    <stringToStringConversion targetType="STRING"/>
    <delimitedListConversion targetType="LIST" valueDelimiter=";" valueQualifier="\&quot;" trimValues="true"/>
    <delimitedTableConversion targetType="TABLE" rowDelimiter="\r\n" valueDelimiter=";" valueQualifier="\&quot;" trimValues="false"/>
  </actions>
  <actions xsi:type="recorder:OpenSpreadsheetAction" active="false" actionDetails="(&quot;C:\Users\bjokv...ktop\rpae.xlsx&quot;)" delay="0" filePath="C:\Users\bjokvi\Desktop\rpae.xlsx" autoSaveFile="true">
    <actions xsi:type="recorder:SetCellValueAction" varType="java.lang.String" active="false" actionDetails="(A1)" delay="10" useCellCoordinates="true" cellCoordinates="A1"/>
    <actions xsi:type="recorder:RepeatAction" active="false" actionDetails="(3 times)" delay="0" repeatsNumber="3">
      <actions xsi:type="recorder:SetCellValueAction" varName="variable" varType="java.lang.String" active="false" actionDetails="(Cell below)" delay="10" cellPosition="CELL_BELOW"/>
    </actions>
  </actions>
  <actions xsi:type="recorder:LaunchAppAction" active="false" actionDetails="(&quot;C:\Program Files (x...; wait for 0ms; poll every 0ms)" delay="0" command="&quot;C:\Program Files (x86)\Microsoft Office\root\Office16\EXCEL.EXE&quot;" autoDetectWindow="true"/>
  <actions xsi:type="recorder:KeyboardAction" active="false" actionDetails="(ENTER)" delay="0" paramString="NATIVE_KEY_PRESSED,keyCode=28,keyText=Enter,keyChar=Undefined,keyLocation=KEY_LOCATION_STANDARD,rawCode=13" text="{ENTER}" rawCode="10" keyCode="28" keyChar="65535" keyLocation="1"/>
  <actions xsi:type="recorder:KeyboardAction" active="false" actionDetails="(Ctrl+s)" delay="0" modifiers="2" paramString="NATIVE_KEY_TYPED,keyCode=0,keyText=Undefined,keyChar='s',modifiers=Ctrl,keyLocation=KEY_LOCATION_UNKNOWN,rawCode=83" text="s" rawCode="83" keyChar="115" type="HOT_KEY_PRESS"/>
  <actions xsi:type="recorder:LaunchAppAction" active="false" actionDetails="(Notepad; wait for 0ms; poll every 0ms)" delay="0" command="Notepad" autoDetectWindow="true"/>
  <actions xsi:type="recorder:WaitAction" active="false" actionDetails="for 1000000 ms" delay="1000000"/>
  <actions xsi:type="recorder:ConstantValueAction" active="true" actionDetails="(to 'variable2' = 2) - Number" delay="0" varName="variable2" varType="java.math.BigDecimal" stringValue="" numberValue="2" booleanValue="false" dateTimeValue="1494939474439" useCurrentDate="false" listValue="rO0ABXNyADRjb20ud29ya2Z1c2lvbi5zdHVkaW8ucnBhLnJlY29yZGVyLm1vZGVsLkxpc3RXcmFwcGVyYmOLQVEsNagCAAFMAAZ2YWx1ZXN0ABBMamF2YS91dGlsL0xpc3Q7eHBzcgATamF2YS51dGlsLkFycmF5TGlzdHiB0h2Zx2GdAwABSQAEc2l6ZXhwAAAAAHcEAAAAAHg=" tableValue="rO0ABXVyABRbW0xqYXZhLmxhbmcuU3RyaW5nOzJNCa2EMuRXAgAAeHAAAAAA"/>
  <actions xsi:type="recorder:RepeatAction" active="true" actionDetails="(5 times)" delay="0" repeatsNumber="5">
    <actions xsi:type="recorder:ExpressionValueAction" active="true" actionDetails="(to 'variable2')" delay="2" varName="variable2" varType="java.math.BigDecimal">
      <bigDecimalExpressionHandler expression="${variable2} * ${variable2}"/>
      <listExpressionHandler operationType="PUSH"/>
    </actions>
  </actions>
  <actions xsi:type="recorder:LaunchAppAction" active="true" actionDetails="(Notepad; wait for 0ms; poll every 0ms)" delay="0" command="Notepad" autoDetectWindow="true"/>
  <actions xsi:type="recorder:KeyboardAction" active="true" actionDetails="(from variable 'variable2')" delay="60" paramString="" varName="variable2" varType="java.math.BigDecimal" text="" type="TEXT_FROM_VAR"/>
  <actions xsi:type="recorder:WaitAction" active="true" actionDetails="for 1000000 ms" delay="1000000"/>
</recorder:ActionFlow>

#5

It seems you’ve encountered a migration bug that existed in RPAex 1.1.0 for some time. As you can see, XML header of you recording contains wrong version number:

xmlns:recorder="http://www.workfusion.com/recorder/v1.0.0"

Please close the tab that shows you the error; open your recording with notepad or other text editor and change namespace manually to

xmlns:recorder="http://www.workfusion.com/recorder/v1.1.0"

Save your changes and reopen your recording with Sunbird.

This solution should be applied to all scripts that were made with your previous RPAex. I’m sorry for this inconvenience.


Unable to open recordings in latest version 1.1.6
Bussiness process has processing issues
Not able to Create new Recording
Unable to open Rpa recorder
UI issue in IF ELSE
#6

Thanks, it’s fine now!


#7

Hi
I just upgraded from 1.1.0 to 1.1.1. I had quite a big script created in 1.1.0 but now I am not able to load it into the RPA recorder. Followed the instructions of the other thread where it says change

xmlns:recorder="http://www.workfusion.com/recorder/v1.0.0"
into
xmlns:recorder="http://www.workfusion.com/recorder/v1.1.0"
in the .rpae file. But still no luck.

What are the right steps to open an existing recording in RPA Recorder? is it done via “File-Import”?

Thanks a lot!


#8

@timriewe - see the info above


#9

Hi, as I said I did see that info but I couldnt get it to work.

What are the detailed steps when you say “reopen your recording with Sunbird”?

Thanks!


#10

close the RPA Recorder, start it again, open your recording


#11

There is no open recording option


#12

You need to find the .rpae file in the Media files panel


#13

I think something is messed up with my workspace. Nothing shows up in the media files panel. How do I get projects and files to appear trhere?


#15

@timriewe - File > Switch Workspace > Other
C:\Users${your_user}\workfusion-workspace


#16

That did it, after I also deselected a working set I had selected previsously.
Thanks!


#17

I’ve installed the latest version of RPA Express. When opening files I get the massage shown underneath. Now I can’t use most of recordings I’va made anymore. How could this be solved?


#18

I also have the same issue is there a solution for this?


#19

@Peter_van_Rooij2, @Elias_Michael1

try the solution in Scripts not migrated to v 1.1.1


#20

Hi I had similar problem with my recording created in 1.0.2. Now i have installed the latest version - 1.1.2 and i am unable to open the recording. I followed the steps as mentioned above. Open the file with text editor manually modify the version, and then close and re-open. But i still am getting the same error - below are the first few lines of the file - Where i have updated the version for the to 1.1.2 . Please let me know if i am missing to modifiy any thing else.

<?xml version="**1.1.2**" encoding="UTF-8"?>

<recorder:ActionFlow xmi:version=“1.1.2” xmlns:xmi=“http://www.omg.org/XMI” xmlns:xsi=“http://www.w3.org/2001/XMLSchema-instance” xmlns:recorder=“http://www.workfusion.com/recorder/v1.1.2” ignoreDelays=“false”>


#21

You’ve changed the version of XML instead of Recorder.
Change this line
xmlns:recorder=“http://www.workfusion.com/recorder/v1.1.2


#22

Thanks! It helped… keeping the other versions as is and changing only the recorder one.