$ sign causing script to fail


I have a remote computer i have to access. the computers IP address comes with a dollar symbol “$”. as a result the script keeps failing when it gets to the IP address. Kindly advise if there is a workaround for me to be able to use the dollar sign.



Hi @MalusiSBS what action fails? Can you share the screenshot of the action and the error message?

Dollar sign error.docx (204.0 KB) Hi @ashapkinaplease see attachment

Try putting the path in a string variable, and then use use the variable in the action.

dollar within string error.docx (214.2 KB) @ashapkina i tried that and i am still getting the same error message. it is failing in the “get folder” action. i was able to use as string variable in a “enter keystroke” action in order to access the folder on explorer. it is just the get folder contents that keeps failing

@ashapkina Hi have you had a chance to look into my issue

not valid directory.docx (121.5 KB) @ashapkina please see attached. i saved the path as a variable. the error message is different. it is now “specified path is not directory”

Is this directory on the same machine that the application is installed on?

Hi Ashapkina. It is not on the same machine. it is on a different machine . There is a folder in that machine which collates data that i need to get daily.

You cannot read the folder that is located on another machine. Files and Folders actions work on the local machine only.

Hi Ashapkina

i was able to create a workaround by mapping the folders onto my computer thereby forgoing the need to use a $ sign. the issue with this is there are several folders i have to map. i actually ran out of drive letters. so i can use files and folders in that way. i need to find a way to do so without mapping each folder i have to access.

1 Like