Studio is slow in latest versions

Hi,

Studio has become much slower in running scripts in latest two RPA versions, 2.0 and 1.9. It takes about second to begin performing next action.

In preferences delay is set to zero. Tried to to change it to another value, 10mm, but with no influence.

In one script is excel file with about 100 rows. From every row script reads three values, and this happens about 100 times. So it takes very long to perform script in studio. When launched from Control Tower, speed is normal.

-mikko

Hi Mikko, is it happening to all actions when they are played in studio, or just to certain ones like keystrokes, etc.?

Hi,

All actions.

-mikko

It might be that for each row action with excel is slow.

Just run one of our scripts and we have delays in actions, so can’t say if all actions are slow. But for each row have became slower any way.

Thanks for info Mikko, we’ll test such use case on the latest version.

The exact same thing happens to my machine too, after upgrading to 2.0

@halmi_nordinqK @mikkoVKXBiWReM if you want to play the scripts from the Studio, not Control Tower, you can speed them up by exporting the recording to a bot task and playing it from the Code perspective - the execution should be faster.

@mikkoVKXBiWReM @halmi_nordinqK perhaps, this fix can help this issue, too Express 1.1.8 also freezes

@mikkoVKXBiWReM @halmi_nordinqK
Version 2.1.0 has performance improvements for Switch to window action and actions in loops. Hope they will help in your case.

Please let me know if you have a chance to try it out.