Switch to Browser Action Failed

Hello Guys,

I know, the first answer here always is “attach a recording”, but I cant, since my project is kind of disclosed.
So I’ll try to explain the problem, and would be very happy if someone is able to help me anyways:

I opened a Browser with the Open Website option. I switch between Excel sheets and Browser quite often. Once, inside the Switch to Browser action, I have a mouse click action that leads to a pop up window, which I directly close by ESCAPE. Then I switch back to Excel and the next time I switch to the Browser, the above error occurs (Switch to Browser Action Failed). If I onlye remove the mouse click-ESCAPE action, everything works fine. Does anyone have an idea? Could this be due to the popup (where I only have to press “ok” or “cancel”)?

Thank you in advance!

This error also happens on other pages as soon as some kind of popup stuff is involved…

Hey again, Guys,

I now created an example on an arbitrary website. You can find it attached. After switching to Notepad and then trying to go back to the Browser the way you normally do it, the action fails.
What is the problem?

Bests and thank you!
Example.zip (70.5 KB)

hi @khenrichs,

Thanks for reporting this issue - we will fix it in the next release. It happens because the URL of the website changed from
http://turnier24.de/ to http://turnier24.de/turniere_editieren/

Meanwhile you can try to do one of the following:

  • all necessary actions in one Open Website action group and then open notepad (and use Launch Application action)
  • as the last action in browser, go to the http://turnier24.de/ page again

Hi azinchuk,

thanks for your reply! Just for clarity: This is just an example process. The process I am creating for a use case is way more complex.
I already tried the solutions you mentioned. Firstly, the process I run cannot be put in only one open website action.
Secondly: The last action in the Browser doesnt seem to matter. Even if I go to http://turnier24.de/ again, the switch to Browser action fails.

Hey again,

I don’t have the feeling that this problem is solved. Or to say it in a different way: I have doubts, that the issue will be fixed in the next release. That’s why I replay again:
The issue is not, that the URL has changed. I dont know exactly what the problem is, but maybe it’s worth looking at it again?

Bests and thank you!

thanks, we will investigate.

@azinchuk, i am also facing switch to browser issue. In my scenario following are the steps:

  1. open salesforce.
  2. Download an excel file.
  3. Filter the downloaded excel file
  4. Switch back to salesforce and perform other relevant actions.
    My recording fails while switching from excel to browser after excel filtering step.

Hi @shivangee_sunX before switching to the browser using Switch to browser action, try switching to the browser window using Window action.

@ashapkina If i use window action, i will not be able to use mouse click on web elements. Please suggest.

You can still use it under Switch to browser action

Thanks for the quick support. it worked for me!

1 Like