Switch to Browser - Mouse Click does not support "Click on web element" feature, why?

xpath
switchtobrowser
mouse-click
webelement

#1

I have faced some problems lately because WorkFusion does not allow us to open up multiple websites simultaneously and now discovered that the xpath-based feature does not work for Mouse Click when we use “Switch to Browser” :-\ It works for the Web Element though.

I’m pretty sure that I am doing it right and it is a miss at WorkFusion side. However, if anyone else work with this - please share your comments.

I really would like to see this feature being part of the next version/release and would appreciate your vote for this.


#2

@haider_raza,

please post your example here - it can be short - just to show what is not working


#3

We have an issue when you want to create a mouse click inside the Switch to browser, but there is a workaround:

  1. create a Mouse Click action inside the Open Website action
  2. select the “Click on Web element (XPath)” option
  3. drag this Mouse Click action inside the Switch to Browser action.
  4. paste your XPath into the “XPath of the target element” field. The “Click on Web element (XPath)” option will not be displayed on UI but it will work.

This behavior will be fixed in the 1.1.4 release.

switch-to-browser.zip (1.6 KB)


#4

Thanks for a quick response. The problem is that I do not see the data field “Xpath of the target element” to paste the xpath of the element.

Here is the screen visual.

I can see that in the project you share but when I tried to created a new one, data field is gone. I don’t know if I am missing something here? By default the “Click on image” radio button is selected and I do not see any option to unchecked (which is the case in the project you shared).


#5

please repeat the actions exactly in the same order as I’ve described - and it should be visible


#6

Got it - it worked, thanks. However I had to copy and paste the action as I cannot drag it. It is kinda locked.