Switch Window action failing in version 1.1.6


#1

Hi
I recently upgraded to v 1.1.6
I am getting error in “Switch Window” action. I wasn’t getting this error in earlier version. I can see the window option but still error comes.
The error is -

Thanks.


#2

Hi @urvashi.singla
Please attach an archived recording to help us investigate the issue. Thanks

-Nataliya


#3

Hi,
PFA the zip file. IATraining.zip (2.6 KB)


#4

@urvashi.singla,

Is your Excel file open? “Stock Performance - Excel”


#5

Yes. It open fine.


#6

#7

#8

any help here?


#9

Have had similar issue. Re-did all the Window Actions and that seems to clear it up. But problem was intermittent and occurred more often in the scheduler.


#10

try to use the Part of window title option


#11

Tried both. Also created a brand new recording in new workspace. Still facing similar issue. Also facing issue when try to open Outlook.


#12

The Window action issues should be fixed in 1.1.8 when we introduce a new automation driver


#13

By when should we expect it?


#14

in 3 weeks


#15

I have the same issue.
Version 1.4.0-beta

error details is attached
Test1_Error.txt (7.3 KB)


#16

Hi, @alina_grishanova
can you also share node logs
you can find it in $INSTALL_DIR/RPA/logs
There should be a Node log file
please, attach it here


#17

I found only this log filerpa-node0-2018-04-06.0.log (157.8 KB)


#18

Thank you, @alina_grishanova
there was an issue with window() action, which will be fixed in next release
try to use window() action without timeout


#19

Could you please advice:
What do you mean “without time out” ? As I see I have [0] time out

Command duration or timeout: 0 milliseconds


#20

I have same problem with two recordings, worked fine before updating to 1.4.

Timeout is 0 milliseconds.