There is no connection to Control Tower

I can’t access to Control Tower in version 2.3.1, and after trying to reinstall RPA Express I cant select the one with the server version included, is there any solution to this, or have access to a previous version?
Regards

What version of RPA Express have you downloaded from the website?

To have Control Tower, you need to download RPA Express Pro.

Is the server from the pro version disabled after the trial?

No, you can still use the server after that. You will just have only 1 bot after the trial. So if you choose 1 bot during the installation, nothing will change for you after the trial.

Seems like I am getting this same issue while upgrading from 2.3.0 to 2.3.6

Hi @peke_robot could you provide more details about the issue?
Cannot you access Control Tower?

Yes, cannot connect to Control Tower. Tried to deinstall and reinstall but without success. I think I have the right download as in the installer ‘resources’ folder there is the installation file for the Control Tower there. Any recommendations where to start investigating root cause for the issue?

1 Like

What message do you see in the Components tab?
Does it say that the server components are not found?
Please share a screenshot.

If it says “not found”, try this solution from the troubleshooting guide
https://kb.workfusion.com/display/RPAe/Troubleshooting#expand-Servercomponentsarenotfound

here’s screenshot attached

Does Control Tower open when you click on the link on the Tab?
If it keeps loading, there might be a delay due to low performance. Try waiting some time for it to load.

Clicking the link - it does open browser and tries to open localhost:15280/workfusion.

ry waiting for some time for it to load without restarting RPAx or the server. Sometimes it can take up to 20-30 minutes for all components to start.

I’ve waited for couple of hours without success. Are there any logs that I should look into.

Yes, please send these logs:

  • C:\RPAExpress\Studio\logs
  • C:\RPAExpress\Agent\Logs
  • C:\RPAExpress\Workfusion\tomcat\logs

Also, please share the screenshot of the Server profile in the Studio and the screenshot of your system properties.

Sent the logs in a separate message

Thank you @peke_robot. Looks like there is some issue with the Secrets Vault installation.
In the folder С:\RPAExpress\Vault\logs, you should have a file. Please send it.

vault.log (12.7 KB)

log attached

1 Like

Hi @peke_robot.
Can you please switch off server components as on my screenshot below, then exit RPA Express?
image
Then please start it again as Administrator, wait till OCR is green and the try to switch on the rest components. Will this work in this case?

2 Likes

Fantastic - this worked nicely. How trivial this ended up being…:smile:

2 Likes