Typing skip few words

Hi,

I got problem when use Keyboard - Enter Keystroke.
I try to type a few words such as “The quick brown fox jumps over the lazy dog”, sometimes it just give me like:

  • The quick brwn fox jumps over the lazy dog
  • The quick brown ox jumps over the lazy dog

Is there any solution for my problems?

Thank you.

Hi William,

Yes, we are aware of this issue.
We are planning to add an option to control the speed with which the text is typed, but not in the nearest future.

Right now, there is no way to control the speed of text input in Recorder, only in the xml config in the “code” perspective, by setting a delay fpr SendKeys actions.

<capability name="extra.autoit.options">
     <script return="optionsMap"><![CDATA[
         optionsMap = ['SendKeyDelay':20,'SendKeyDownDelay':55]
     ]]></script>
</capability>

In recorder, you can use this workaround: save the text in a variable, copy iy to clipboard and paste using Ctrl+V

Hi Ashapkina,

Thank you for your fast response.
I am wondering if I could use the custom action script.

I was reading in the API Documentation (Workfusion API 9.2.0.4) about Clipboard, and suggested to use RobotClipboard and in the usage page, tell me to use RPA.clipboard(), but instead of getting RobotClipboard, I got ScreenClipboard.

Is there any solution for this?

Thank you.

What do you want to do in the custom action, paste the value stored in Clipboard?