Unable to click on "Publish to Workfusion" Icon - RPA Express

issues

#1

Hi Team,

I am unable to click on “Publish to Workfusion” icon - RPA Express. I attached here the screen shot of the issue.

Please suggest what to do to come out from this issue.

Thanks,
ajayso


#2

Hi, @ajayso, please, try right-click on recording folder and click “Export as new script”


#3

Hi

I am also facing the same issue still by clicking on the above two option nothing happens

Please suggest
Thanks
Abhishek


#4

i encounter the same issue after i change the directory of file system. after i moved everyting back to rpae_project folder, the publish to control tower button works sweet


#5
  1. Please, make sure WF is running, if not start it
  2. Try to create a new recording and export it, to see if problem occurs with a particular script
  3. Please, clarify, what do you mean by “unable to click” do you have any pop-up widow after click, or nothing happens?
  4. Please send us zip with log files of recorder. You can find it "C:\Users${user}\workfusion-workspace"
    Add to archive .metadata folder and attach it here, please

#6

Hi RPA Team,

I tried all the suggestions provided by the forum, still I am facing the same issue as below :

  1. After clicking on “Export as new recorder script”, nothing happenes.
  2. Unable to click on “Publish to Workfusion” Button.
  3. Unable to open “Control Tower”.

Please give suggestion to overcome from this situation.
Thanks,
ajayso


#7

Ok, so as i see Control Tower does not work. Thats the reason you can not export script.
Please, send us report
Note: You need to attach zip archive as, will be mentioned


#8

Hi mzhalniarkevich,

I upload here the log files as per your suggestion.

rpa-hub-2017-05-05.0.zip (126.6 KB)

Thanks,
ajayso


#9

Hi, @ajayso, Did you change login or pass in Control Tower?


#10

Hi mzhalniarkevich,

No, I have not change any login password in Control Tower.

Thanks,
ajayso


#11

@ajayso - please update to the latest RPA Express 1.1.0 version by re-registering on the WorkFusion website, downloading a new installer, uninstalling the current version and installing the new one.


#12

Hi Azinchuk, is there any other way to resolve the publishing problem. I have changed the password of control tower. while publishing I am getting error… Wrong User Name or Password"


#13

Hi, @swapnil_pandey1
Please edit config.ini file, which is located in
${INSTALL_DIR}\Recorder\configuration

On line 19 replace workfusion with your current pass, save file and restart recorder app


#14

Hi, this is also happening to me after upgrading to 1.1.0 (in previous versions worked fine; upgrade was done uninstalling before installation):

· Publish to Control Tower button does nothing.
· Export as existing or new recorder script also no action, no error displayed.
· Export…/Workfusion Recorder/Export recorder script as new business process lets put a Step name but recorder script file list is empty (please find capture)

I’ve Tried without success:

· Exiting and opening all again
· Starting Control tower before RPA Recorder (waiting for full startup before continuing, takes a while).
· Restarting everything (including Windows) and starting again.
· Creating a new recording and trying to export it.

Same result every time.

I have never changed Control Tower password or moved rpa_project folder from its default location.

Hope it helps.
Kind Regards.


#15

This worked for me.


#16

Thank you so much :slight_smile: - working fine now. :slight_smile:


#17

Hi, solved in my case! Different problem,

I made a backup of some recording and then there were two .rpae files with the same name on different directories confusing Workfusion Recorder.

I discovered it after opening c:\Users<user>\workfusion-workspace.metadata.log and seeing a java.lang.IllegalStateException: Duplicate key L/rpae_project/xxx/xxx.rpae exception.

Renaming the .rpae file in the backup solved the issue.

Some captures follows:

Kind Regards


#18

@Gregorio_Santander1 - good investigation!

See this article for more details - https://kb.workfusion.com/display/RPAe/RPA+Recorder#RPARecorder-MediaFiles


#19