Unable to connect to robot - Workfusion 2.3.0

Hello

I am not able to play a recording in studio since I installed version 2.3.0. I read a few posts and the following solutions did NOT work for me:

  • regsvr32 %INSTALL_DIR%\RPA\autoit\AutoItX\AutoItX3_x64.dll
  • disable the firewall

I was able to publish to Control Tower, but I haven’t tried to run the process from there.

I attached some logs. They begin when I start Workfusion and minutes later at 17:53 I tried the playback but without success.

Here is the error message I get in Studio:

com.workfusion.studio.rpa.recorder.player.driver.DriverInitializationException: Unable to connect with robot
at com.workfusion.studio.rpa.recorder.player.driver.RpaUniversalDriver.connect(RpaUniversalDriver.java:127)
at com.workfusion.studio.rpa.recorder.player.driver.RpaUniversalDriver.initialize(RpaUniversalDriver.java:64)
at com.workfusion.studio.rpa.recorder.player.PlaybackLogic.run(PlaybackLogic.java:75)
at java.lang.Thread.run(Thread.java:745)
Caused by: org.openqa.selenium.remote.UnreachableBrowserException: Could not start a new session. Possible causes are invalid address of the remote server or browser start-up failure.
Build info: version: ‘9.3.0.5’, revision: ‘63553f3f1c’, time: ‘2019-03-15T13:41:27.26Z’
System info: host: ‘PM182027’, ip: ‘10.9.28.194’, os.name: ‘Windows 7’, os.arch: ‘amd64’, os.version: ‘6.1’, java.version: ‘1.8.0_121’
Driver info: driver.version: RpaUniversalDriver
at org.openqa.selenium.remote.RemoteWebDriver.execute(RemoteWebDriver.java:762)
at org.openqa.selenium.remote.RemoteWebDriver.startSession(RemoteWebDriver.java:265)
at org.openqa.selenium.remote.RemoteWebDriver.startSession(RemoteWebDriver.java:247)
at org.openqa.selenium.remote.RemoteWebDriver.(RemoteWebDriver.java:148)
at org.openqa.selenium.remote.RemoteWebDriver.(RemoteWebDriver.java:185)
at com.freedomoss.crowdcontrol.webharvest.selenium.wrapper.RemoteDriverWrapper.(RemoteDriverWrapper.java:39)
at com.workfusion.studio.rpa.recorder.player.driver.RpaUniversalDriver.connect(RpaUniversalDriver.java:125)
… 3 common frames omitted
Caused by: org.apache.http.conn.HttpHostConnectException: Connect to 127.0.0.1:8888 [/127.0.0.1] failed: Connection refused: connect
at org.apache.http.impl.conn.DefaultHttpClientConnectionOperator.connect(DefaultHttpClientConnectionOperator.java:151)
at org.apache.http.impl.conn.PoolingHttpClientConnectionManager.connect(PoolingHttpClientConnectionManager.java:353)
at org.apache.http.impl.execchain.MainClientExec.establishRoute(MainClientExec.java:388)
at org.apache.http.impl.execchain.MainClientExec.execute(MainClientExec.java:236)
at org.apache.http.impl.execchain.ProtocolExec.execute(ProtocolExec.java:184)
at org.apache.http.impl.execchain.RetryExec.execute(RetryExec.java:88)
at org.apache.http.impl.execchain.RedirectExec.execute(RedirectExec.java:110)
at org.apache.http.impl.client.InternalHttpClient.doExecute(InternalHttpClient.java:184)
at org.apache.http.impl.client.CloseableHttpClient.execute(CloseableHttpClient.java:71)
at org.apache.http.impl.client.CloseableHttpClient.execute(CloseableHttpClient.java:55)
at org.openqa.selenium.remote.internal.ApacheHttpClient.fallBackExecute(ApacheHttpClient.java:139)
at org.openqa.selenium.remote.internal.ApacheHttpClient.execute(ApacheHttpClient.java:87)
at org.openqa.selenium.remote.ProtocolHandshake.createSession(ProtocolHandshake.java:337)
at org.openqa.selenium.remote.ProtocolHandshake.createSession(ProtocolHandshake.java:135)
at org.openqa.selenium.remote.HttpCommandExecutor.execute(HttpCommandExecutor.java:142)
at org.openqa.selenium.remote.RemoteWebDriver.execute(RemoteWebDriver.java:741)
… 9 common frames omitted
Caused by: java.net.ConnectException: Connection refused: connect
at java.net.DualStackPlainSocketImpl.waitForConnect(Native Method)
at java.net.DualStackPlainSocketImpl.socketConnect(DualStackPlainSocketImpl.java:85)
at java.net.AbstractPlainSocketImpl.doConnect(AbstractPlainSocketImpl.java:350)
at java.net.AbstractPlainSocketImpl.connectToAddress(AbstractPlainSocketImpl.java:206)
at java.net.AbstractPlainSocketImpl.connect(AbstractPlainSocketImpl.java:188)
at java.net.PlainSocketImpl.connect(PlainSocketImpl.java:172)
at java.net.SocksSocketImpl.connect(SocksSocketImpl.java:392)
at java.net.Socket.connect(Socket.java:589)
at org.apache.http.conn.socket.PlainConnectionSocketFactory.connectSocket(PlainConnectionSocketFactory.java:74)
at org.apache.http.impl.conn.DefaultHttpClientConnectionOperator.connect(DefaultHttpClientConnectionOperator.java:134)
… 24 common frames omitted
2019-06-03 17:44:01,303 -0400 INFO [Playback logic] com.workfusion.studio.rpa.recorder.player.PlaybackLogic - Execution takes PT17.163S ms

Thanks in advance!

Hello @alainsirois.

I didn’t find attached logs. Could you please provide an archive with files from folders: C:\RPAExpress\Studio\logs\
and
C:\RPAExpress\RPA\logs\

Did you change any settings in Default server profile? Please provide screenshot of this window from Studio: Window > Preferences > WorkFusion Studio > Server Profiles.
Thank you in advance.

See below attachment:

unable_connect_robot.zip (5.8 KB)

I reinstalled Workfusion so the below setup should be good:

image

Thank you. I saw in your logs strange connection string to one of RPA Express components that responsible for running bots. Did you reinstall RPA Express after your post? If yes, do you able to run recordings as usual?

Hello

I tried reinstalling Workfusion, but it did not work. I did this last week, before I created the screenshots or saved the logs.

In regards to the logs, Workfusion did not load any workspace when it started. That might have caused the discrepancy.

What logs do you mean? According to your logs I see that for some reason bot tried to connect to the port 8888 that is absent in default RPA Express configuration. But according to your server profile it should connect port 15444. Could you please make sure that port 15444 is not blocked on your PC?

When you talked about a strange connection string I thought it was because Workfusion did not load any workspace when it started. I had to do “switch workspace”

I disabled my firewall but it did not fix the problem.

Please show screenshot with your Listening ports.

  1. Go to Task ManagerPerformance tab → Open resource monitor.
  2. Then go to NetworkListening Ports.
  3. Sort list by Port. Then check if anything is using port 15444. Please see how it should look (in my screenshot all good, ‘java.exe’ is using this port to run specific components):
    .
  4. By PID column you can find specific process in Task Manager tab Details and check what the process blocks it.

image

Thank you. I see strange status in your first screenshot:


Do you have any custom network configuration? I would recommend you to check with your local IT what can prevent access to port 15444. Also please check whether you have any Inbound/Outbound rules in your firewall related to port 15444.

Hello

As mentioned before, I was able to disable the firewall before trying to playback my script therefore I believe the issue is somewhere else.

Moreover, I am pretty sure the firewall configuration of my company prevents any kind of reporting/status in the last column; I wouldn’t pay much attention to that.

Could you please also check listening ports for 15410? And please send to me files from folder: C:\RPAExpress\RPA\rpa-grid.

Hello

Requested files are around 100MB. Can you create an FTP account so I can upload them?

Below, requested screenshots:

image

Thank you.

Thank you. So I don’t have any FTP account, but you can zip all files into one archive and upload to some file shared source. You can send link to me in private message.

Hi @alainsirois. Thank you for your files. All looks fine with them. Could you please execute the following commands in Command Prompt?
netstat -an
It should show the list of connections to ports on your PC. Please copy result from Command Prompt (Ctrl-A, Ctrl-C), save to TXT file and attach to your reply.
Thank you in advance.

1 Like

Please see attached file.netstat20190625T1218.txt (16.7 KB)

Thank you. Could you please launch RPA Express and server components and then repeat netstat -an command?

This is what I did before typing netstat -an

Thank you. So did you receive the same error when executing your script?