Unable to connect with Robot - Error

connection
robot
rpa
issues

#1

I was successfully able to install the product and was able to run the program after installing Java 64 bit (as our firm by default has Java 32 bit though our standard issue laptops are all 64 bit). With Java 32 bit and prior to downloading 64 bit, I had an error regarding JVM.DLL and not being able to run. Once I installed the Java 64 bit, I was able to open the Recorder software.

I recorded a tiny script and when I tried to play it back, I encountered an error “Unable to connect with Robot”. I tried recording a couple of other scripts and when I try to play them back, I encounter the same error. Here’s some additional details on the error…can I kindly get some help in finding a resolution?

Unable to connect with Robot
org.openqa.selenium.remote.UnreachableBrowserException: Could not start a new session. Possible causes are invalid address of the remote server or browser start-up failure.
Build info: version: '2.53.0', revision: '35ae25b1534ae328c771e0856c93e187490ca824', time: '2016-03-15 10:43:46'
System info: host: 'MUS215317', ip: '10.114.218.55', os.name: 'Windows 7', os.arch: 'amd64', os.version: '6.1', java.version: '1.8.0_121'
Driver info: driver.version: RemoteWebDriver
  	at org.openqa.selenium.remote.RemoteWebDriver.execute(RemoteWebDriver.java:633)
  	at org.openqa.selenium.remote.RemoteWebDriver.startSession(RemoteWebDriver.java:212)
  	at org.openqa.selenium.remote.RemoteWebDriver.<init>(RemoteWebDriver.java:94)
  	at org.openqa.selenium.remote.RemoteWebDriver.<init>(RemoteWebDriver.java:121)
  	at com.freedomoss.crowdcontrol.webharvest.selenium.wrapper.RemoteDriverWrapper.<init>   (RemoteDriverWrapper.java:44)
  	at com.workfusion.studio.rpa.recorder.processor.ActionFlowPlayer.initDriver(ActionFlowPlayer.java:142)
  	at com.workfusion.studio.rpa.recorder.processor.ActionFlowPlayer.play(ActionFlowPlayer.java:96)
  	at com.workfusion.studio.rpa.recorder.views.PlayerControlWindow.lambda$8(PlayerControlWindow.java:176)
  	at java.util.concurrent.ThreadPoolExecutor.runWorker(Unknown Source)
  	at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source)
  	at java.lang.Thread.run(Unknown Source)

Components - Major Outage
Webinar: Ask me anything about RPA Express
#2

@SNanduru_Capital_One,

this issue occurs because you have your Bot Manager stopped:

To start Bot manager, open RPA Express tray menu and click Start in the Bot Manager section.

If it does not help, choose All Components > Restart


RPA Express - WorkFusion tray menu icon
#3

Azinchuk, thanks for looking into this issue.

I noticed last night that I am unable to start either the control tower or not manager using either the ‘start’ or the ‘all components - start’ options. When I click either of the buttons it takes a few minutes and then just grays itself out…


#4

Have you tried to restart Windows and launch RPA Express (click the appropriate desktop icon or from Start menu > RPA Express)?


#5

Yes! Still the same behavior with being unable to start the control tower or the bot manager


#6

Hi, @SNanduru_Capital_One
Please, Open Platform monitor and Navigate to Command board

Run 2 commands and send us the result please

Also, check Bot manager status after that (in tray menu)


#7

@ mzhalniarkevich

Just replied to your email directly but I am encountering an error while trying to open the platform manager. here’s what I see…

Exception: dns_unresolved_hostname
Exception details: Your requested host “pm.rpa-express.local” could not be resolved by DNS.
Requested URL: http://pm.rpa-express.local:15100/


#8

@SNanduru_Capital_One, please do not write emails to forum@workfusion.com - use this topic to create posts.


#9

Will make sure that I will use this thread to respond going forward.

Can you please help me with identifying the resolution to the above mentioned issues? At this time I still cant connect to the platform manager or start the ‘bot manager’ or ‘control tower’.

Thanks


#10

if you get the following exception:

Exception: dns_unresolved_hostname

Exception details: Your requested host "pm.rpa-express.local" could not be resolved by DNS. 

Requested URL: http://pm.rpa-express.local:15100/

then you need to modify your hosts file and add the following string there:

127.0.0.1 rpa-express.local pm.rpa-express.local

To modify the hosts file, see this tutorial - https://www.petri.com/easily-edit-hosts-file-windows-10


#11

I have modified the hosts file and appended the string “127.0.0.1 rpa-express.local pm.rpa-express.local” as suggested, re-started the machine and still see the same error when trying to open the platform manager. The Bot manage or the control tower couldn’t be started either.


#12

Are you sure that the hosts file was saved correctly (with Admin rights)? Try to open it and check that the added line is there.

Try to execute the following commands from console (Win + R > cmd):

ping rpa-express.local
ping pm.rpa-express.local

The result should be like the following:


#13

Below is what I noticed with the ping command -

C:\Users\loz121>ping rpa-express.local

Pinging rpa-express.local [127.0.0.1] with 32 bytes of data:
Reply from 127.0.0.1: bytes=32 time<1ms TTL=128
Reply from 127.0.0.1: bytes=32 time<1ms TTL=128
Reply from 127.0.0.1: bytes=32 time<1ms TTL=128
Reply from 127.0.0.1: bytes=32 time<1ms TTL=128

Ping statistics for 127.0.0.1:
Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
Minimum = 0ms, Maximum = 0ms, Average = 0ms


#14

and for the ping on “ping pm.rpa-express.local”, here’s what I noticed:

C:\Users\loz121>ping pm.rpa-express.local

Pinging rpa-express.local [127.0.0.1] with 32 bytes of data:
Reply from 127.0.0.1: bytes=32 time<1ms TTL=128
Reply from 127.0.0.1: bytes=32 time<1ms TTL=128
Reply from 127.0.0.1: bytes=32 time<1ms TTL=128
Reply from 127.0.0.1: bytes=32 time<1ms TTL=128

Ping statistics for 127.0.0.1:
Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
Minimum = 0ms, Maximum = 0ms, Average = 0ms


#15

Hi,

is there an update on the topic? I have exactly the same issues as SNanduru_Capital_One.

The hosts file contains the required line, I can ping both rpa-express.local and pm.rpa-express.local.

However I can’t start platform monitior and I can’t play recording.

Network Error (dns_unresolved_hostname)

Your requested host “pm.rpa-express.local” could not be resolved by DNS.


#16

@Aibek_Sarimbekov_PWC
Hello, recently we’ve found a solution to the issue very similar to yours.
Check it in RPA Express User Guide Troubleshooting section


#17

while running sample task using recorder i am getting below eror what might be the issue?


#18

@shravani_muthumula - please see above solutions and do not create new duplicate topics.


#19

ok but according to the above solution mentioned I am unable to see workfusion tray menu.what might be the issue?


#20

If you have installed RPA Express corrextly, the RPA Express tray menu can be launched as described here:
https://kb.workfusion.com/display/RPAe/Platform+Monitor

You can also check the troubleshooting guide:
https://kb.workfusion.com/display/RPAe/Troubleshooting