Unable to connect with robot: Unable to parse remote response

When i isntall the RPA,and try to run an recording example but popup this error.

Hi @wayne_y_yan,

Is the bot manager started in the tray menu?
image

Yes, it’s running!
WeChat%20Screenshot_20180719170829

Open Bot manager from the tray menu, open localhost and check that bot_relay and rpa.bot are running.

If they are running and you still get this error, please send us the logs from:

C:\RPAExpress\RPA\logs
C:\RPAExpress\RPA\wfagent\logs
C:\RPAExpress\Studio
C:\RPAExpress\Studio\logs

rpa-hub-2018-07-19.0.log (5.8 KB)
rpa-node0-2018-07-19.0.log (25.0 KB)
status-agent-error.log (70.9 KB)
studio.log (86.2 KB)

@wayne_y_yan weirdly, the log doesn’t show any exceptions.

Please try running the recording again, and when the exception occurs, press Details>>, copy the whole text of the error log, paste into a .txt file and upload here.

Thank you.

error.log.txt (6.4 KB)

@wayne_y_yan could you please go to Window - Preferences - WorkFusion Studio - Server Profile and check the Bot relay url. It should look like this:

image

It looks like your server profile has the URL of Platform Monitor: http://localhost:15100/

That’s the problem, thanks very much!!!

1 Like

I am also getting same issue. Everything I tried what ever you suggested above, still I am facing that issue in 2.0.4.609 version.

Hi @muralee_vatamb, could you send the details of the error as described above?

Thank you.

I am facing this issue in 2.0.4.609 version.
Error

@muralee_vatamb could you please share error details Unable to connect with robot: Unable to parse remote response

This error usually occurs when the Bot manager is not started in the tray menu.
image
In this case, start it manually and try to play the recording.

Facing same issue,rpa-hub-2018-11-06.0.log (28.1 KB)
rpa-hub-2018-11-07.0.log (12.3 KB)
rpa-node0-2018-11-06.0.log (35.8 KB)
rpa-node0-2018-11-07.0.log (15.6 KB)

Hello, @ashapkina I have the same issue.

  1. I checked Bot manager. It is started in the tray menu.
  2. I checked bot_relay and rpa.bot and they are running
  3. I checked Server Profile

Could you please help me with this issue?
rpa-hub-2019-03-28.0.log (12.4 KB)
studio.log (1.3 MB)
rpa-playback.log (14.7 KB)
status-agent.2019-03-27.0.log (4.4 MB)
metrics.2019-03-27.0.log (6.0 MB)

Hello @volshevska.
Could you please advise your RPA Express version ? You can check version in Control Panel - Programs and Features.
Also please advise whether you changed something on your PC: password, any permissions or Windows updates.

Thank you in advance!

@Lera, hello.
Version 2.2
WorkFusion RPA Express
Lumen.
I haven’t done any changes on my PC.

Thank you a lot

Thank you @volshevska. I recommend you to check the following:

  1. Do you use any proxy on your PC? If yes, please try to disable it temporary and check whether bot will run.
  2. Do you have any firewall rules/Windows defender/antivirus which can block ports 15444 and 15410? You can also check in Resource Monitor, tab Network - Listening Ports whether any process blocks these ports, except Java processes(it’s ok). Please see my screenshot (processes in red rectangle are correct):
  3. Also could you please send files from folder C:\RPAExpress\RPA\logs\ for dates when you faced this issue at the first time? I need files rpa-node-.log and rpa-hub-.log.