Unable to find browser's path in config.ini

issues

#1

I want to open website in browser ( locally in WorkFusion recorder) using action ‘launch browser’.
I’m facing an issue > "Unable to find browser’s path in 'config.ini using key 'com.workfusion.studio.recorder.firefox.portable> ’

Manual changing path in file config.ini doesn’t work. Below is the code of config.ini that I am trying
Could you please help?

#This configuration file was written by: org.eclipse.equinox.internal.frameworkadmin.equinox.EquinoxFwConfigFileParser
#Fri Mar 24 16:56:30 UTC 2017
com.workfusion.studio.recorder.wf.port=15280
com.workfusion.studio.recorder.wf.username=workfusion
osgi.bundles=reference:file:org.eclipse.equinox.simpleconfigurator_1.1.200.v20160504-1450.jar@1:start
eclipse.application=com.workfusion.studio.recorder.recorderApplication
com.workfusion.studio.recorder.wf.host=http://rpa-express.local
eclipse.p2.profile=DefaultProfile
osgi.framework.extensions=reference:file:org.eclipse.osgi.compatibility.state_1.0.200.v20160504-1419.jar
com.workfusion.studio.recorder.firefox.portable=C:Program Files (x86)\Mozilla Firefox\firefox.exe
osgi.bundles.defaultStartLevel=4
org.eclipse.ui/org.eclipse.ui.edit.text.encoding=UTF-8
osgi.framework=file:plugins/org.eclipse.osgi_3.11.3.v20170209-1843.jar
org.eclipse.core.resources/encoding=UTF-8
eclipse.product=com.workfusion.studio.recorder.ide
com.workfusion.studio.recorder.wf.password=workfusion
com.workfusion.studio.recorder.logging.history.maxdays=30
osgi.instance.area.default=file:workfusion-workspace
org.eclipse.equinox.simpleconfigurator.configUrl=file:org.eclipse.equinox.simpleconfigurator/bundles.info
perspective=com.workfusion.studio.recorder.perspective
osgi.splashPath=file:plugins/com.workfusion.studio.recorder
com.workfusion.studio.recorder.hub.url=http://localhost:15444/wd/hub
osgi.instance.area=file:workfusion-workspace
equinox.use.ds=true
group.windows.postprocessor.enabled=true
com.workfusion.studio.recorder.logging.history.maxsize=3GB
eclipse.p2.data.area=@config.dir/…/p2


#2

Hi @nwojcik,
This is a known bug with an older version of the software. I’ll email you an updated version where this action should work.
By default all existing beta users will get an update April 10th.

Thanks,
Pooja


#3

Work fusion is looking for Firefox and since it’s not installed on your machine, it throws an error.

An alternative would be to use Launch application and select chrome.exe (C:\Program Files (x86)\Google\Chrome\Application\chrome.exe) if that’s what you want. Same with IE.


#4

"ajay.konda, I have tried your alternative suggestion (the action Launch application instead launch browser) and it doesn’t work. There are strange goings-on, I can see that chrom browser is up for 2 sec and then unexpectedly is closed moreover Workfusion recorder marked this step as successfull. I’am going to wait for next release April 10th.

I really appreciate your help :wink: )