Unable to install 1.1.5-beta - error 0x80070643

installation
issues
0x80070643

#1

I’m having the same issue as a lot of other people - the installer fails with this error:

[26F8:271C][2017-10-02T10:44:22]i301: Applying execute package: WorkFusionRPAExpress.msi, action: Install, path: C:\ProgramData\Package Cache{940B81FE-080D-4F90-9869-DFDF869F53FD}v1.1.5\resources\WorkFusionRPAExpress.msi, arguments: ’ ARPSYSTEMCOMPONENT=“1” MSIFASTINSTALL=“7” WIXBUNDLEORIGINALSOURCE=“C:\Users\psadmin.NKPROC16\Downloads\Compressed\RPAExpressInstaller.exe”’
[26F8:271C][2017-10-02T10:55:16]e000: Error 0x80070643: Failed to install MSI package.
[26F8:271C][2017-10-02T10:55:16]e000: Error 0x80070643: Failed to execute MSI package.
[2A08:0E38][2017-10-02T10:55:16]e000: Error 0x80070643: Failed to configure per-machine MSI package.
[2A08:0E38][2017-10-02T10:55:16]i319: Applied execute package: WorkFusionRPAExpress.msi, result: 0x80070643, restart: None
[2A08:0E38][2017-10-02T10:55:16]e000: Error 0x80070643: Failed to execute MSI package.
[26F8:271C][2017-10-02T10:55:16]i318: Skipped rollback of package: WorkFusionRPAExpress.msi, action: Uninstall, already: Absent
[2A08:0E38][2017-10-02T10:55:16]i319: Applied rollback package: WorkFusionRPAExpress.msi, result: 0x0, restart: None

I have re-downlaoded the package using a download manager, checked that I don’t have any firewall etc, and still no joy. What else can I look for?


#2

Did you extract the content completely or run it from the RAR application window?

Best Regards,
Ainur Tokenova
Workfusion Support


#3

I extracted it fully. I have tried numerous times in different ways. I did just manage to get further by creating a folder for it first and making sure the SYSTEM account has full permissions on the folder. Now I get this error:

Error 1335. The cabinet file ‘cab30.cab’ required for this installation is corrupt and cannot be used. This could indicate a network error, an error reading from the CD-ROM, or a problem with this package.
MSI (s) (0C:08) [13:02:16:042]: Product: WorkFusion RPA Express – Error 1335. The cabinet file ‘cab30.cab’ required for this installation is corrupt and cannot be used. This could indicate a network error, an error reading from the CD-ROM, or a problem with this package.

The strange thing though is that that cab file inside the resources folder is perfectly fine.


#4

Dear @nking,

Can you please try to re-download the package and get back to us?

Best Regards,
Ivan Kavaleu


#5

When is 1.1.6 expected? :slightly_smiling_face:


#6

Same issue


#7

@Jens_Jespersen5,

1.1.6 is available now!

:ribbon:


#8

Just got the download email today and got the same error with 1.1.6.
Installer says it’s 1.1.6-beta not GA?


#9

Please see our troubleshooting guide - https://kb.workfusion.com/display/RPAe/Troubleshooting#expand-Errorcode0x80070643


#10

My IT department has followed your instructions for this problem. First, they extracted it fully and tried to install, but received the same 0x80070643 error. They then turned off the antivirus, extracted it fully and installed it, but they still got the same 0x80070643 error. Any solution for this?
Thank you in advance.


#12

I’ve got the same problem. I don’t have anti-virus blocking. I had the old version before installed it.
I removed all old files and after tried to install new version.
I tried to redownload the software and didn’t solve the problem. I tried to add a registry key valeu in regedit and nothing.

I don’t have more ideas to solve the problem. I’m using virtual machine with Windows server 2016, and i had the old workfusion version. Here is the log error:

.WorkFusion_RPA_Express_20171016101529.log (21.5 KB)


#13

Did you run as admin? Looks like it has a problem with executing the MSI


#14

Yes, we attempted to install it as admin.


#15

Yeah try re extracting it. Make sure you are installing off of a local drive.

If that doesn’t work, redownload it.

Edit:
Post system specs
Logs


#16

I’ve decided to give up -wasted too much time re-downloading, re-extracting, changing folder permissions etc.


#17

Hi, see attached system info and logs.

Downloaded several times on different networks/Internet connections.

Ran as admin, installed from binaries on local drive to local drive.

Note: This was done by our IT department, and we install applcations frequently without issues.

DxDiag.txt (60.2 KB)

WorkFusion_RPA_Express_20171017100037.log (21.6 KB)


#18

I solved the problem.
It was necessary to download the last java version.
Try it.


#19

Thanks, but installing the latest java version didn’t work for us.