Unable to open Control Tower in RPA Express

issues

#1

Hi,
I have installed the RPA Express beta version, and try to understand the tools. After successfully recording the process via RPA Recorder, I published to work fusion and got the success pop-up “Successfully exported recorder script to Control Tower.”.

After this I click on “Open in Control Tower” button, I got the below error :
The requested URL can not be retrieved.
Unable to connect remote web server.

below is the url :
URL rpa-express.local/workfusion/secure/business-process/edit/17a7989d-0586-488b-8b6b-d55482d45757?actTab=WORKFLOW_DESIGNER

I already read the related link (Unable to start Control Tower) from Forum.

Please suggest me how I am able to open the Control Tower,
Is any configuration required for Control Tower ?

Below is the error screen shot :-

Thanks,
Ajay Soni


#2

hi @ajayso,

Can you log in to Control Tower?

See our troubleshooting guide - https://kb.workfusion.com/display/RPAe/Troubleshooting


#3

Hi @azinchuk,

I am unable to login in Control Tower. I have seen the given trouble shoot link.
Below is the status of the ports I have checked :
Port Details Status
15100 - Platform Monitor Yes
15110 - S3 File Storage Yes
15280 - Nginx No
15380 - Tomcat Yes
15306 - Mysql Yes
15423 - Postgres No
15444 - RPA Grid Yes
15410 - 15415 - RPA Node No


#4

Have you tried to restart all components using Platform Monitor?

If it does not help, send us report using the Send report function.


#5

Hi,
Just to check what all is failing. Exit from RPA.
Then go to your command prompt and open the C:\RPAExpress\Workfusion in which it is installed. Post that run: start-wf.bat.
It will run all the necessary components in separate windows. You can go through them to figure out which one is failing.


#6

Hi RKumar,

I have run start-wf.bat as per your suggestion, It opened all the components in different windows and installed. Status is as below :

MySQl : Not completed
nginx : Issue - daemon off
minio : Issue - invalid bucket name
postgrease : OK
tomcat : OK

After this I am again trying to start the Control Tower, and getting the same error.

Thanks,
ajayso


#7

Yes, that was just an alternate way to see what problems you might have. That will not resolve your issue.
It would just give you an idea as to which component might giving you issues.


#8

Hi ,
I think there is some issue with below components :
Mysql, nginx, minio .

I got below error screen in Platform Monitor :

Thanks,
ajayso


#9

Hi,
I am no expert. However, for me I had to re-install because of these errors.
Can you check you installation log and make sure that the installation was done without error?
You should find installation logs under temp folder.


#10

Hi @azinchuk,

I am unable to open the Control Tower. I have trying all the possibilities from my side.
I have attached here the log file of Installation of RPA Express.

Please suggest me to come out from this issue.

Thanks,
ajayso

WorkFusion_RPA_Express_20170406114023.zip (2.8 KB)


#11

According to your answer, the above listed ports are closed. This is the reason why Control Tower is not working.

You need to free these ports by:

  • closing applications that use these ports
  • using different ports for applications that use these ports
  • opening these ports in your Firewall and/or Anti-virus
  • restarting your PC (maybe you’ve started Control Tower several times and old processes are still alive)

#12

hi,
I am facing similar issue.
In Platform monitor - Components is showing as PostgreSQL outage. Although I have tried stopping and starting the PostgreSQL server through Command Board but I am still facing the same issue.
I can see PIDs listening to port 15423 when I do netstat.

C:\RPAExpress\Workfusion>netstat -aon|find "15423"
TCP 127.0.0.1:15423 0.0.0.0:0 LISTENING 7848
TCP 127.0.0.1:15423 127.0.0.1:57612 ESTABLISHED 7848
TCP 127.0.0.1:15423 127.0.0.1:57614 ESTABLISHED 7848
TCP 127.0.0.1:15423 127.0.0.1:57615 ESTABLISHED 7848
TCP 127.0.0.1:15423 127.0.0.1:57616 ESTABLISHED 7848
TCP 127.0.0.1:15423 127.0.0.1:57617 ESTABLISHED 7848
TCP 127.0.0.1:15423 127.0.0.1:57618 ESTABLISHED 7848
TCP 127.0.0.1:15423 127.0.0.1:57619 ESTABLISHED 7848
TCP 127.0.0.1:15423 127.0.0.1:57620 ESTABLISHED 7848
TCP 127.0.0.1:15423 127.0.0.1:57704 ESTABLISHED 7848
TCP 127.0.0.1:15423 127.0.0.1:57862 ESTABLISHED 7848
TCP 127.0.0.1:57612 127.0.0.1:15423 ESTABLISHED 9888
TCP 127.0.0.1:57614 127.0.0.1:15423 ESTABLISHED 9888
TCP 127.0.0.1:57615 127.0.0.1:15423 ESTABLISHED 9888
TCP 127.0.0.1:57616 127.0.0.1:15423 ESTABLISHED 9888
TCP 127.0.0.1:57617 127.0.0.1:15423 ESTABLISHED 9888
TCP 127.0.0.1:57618 127.0.0.1:15423 ESTABLISHED 9888
TCP 127.0.0.1:57619 127.0.0.1:15423 ESTABLISHED 9888
TCP 127.0.0.1:57620 127.0.0.1:15423 ESTABLISHED 9888
TCP 127.0.0.1:57704 127.0.0.1:15423 ESTABLISHED 9888
TCP 127.0.0.1:57862 127.0.0.1:15423 ESTABLISHED 9888
TCP [::1]:15423 [::]:0 LISTENING 7848

Please let me know what should I do to resolve the issue.

Thanks,
naman


#13

@NDeep_P

Your logs contain the following line:

< 2017-04-17 05:50:17.307 EDT >FATAL:  could not create shared memory segment: error code 1450

It means your system is running out of RAM.

Your report shows that you have 8GB of RAM, but you apparently have some other resource-consuming processes running at the same time, therefore you need either to close resource-consuming applications or add more RAM.