Unable to publish to Control Tower in 2.0: Unauthorized

issues
control-tower
publish

#1

Hi,

I am experiencing the following error when publishing from WorkFusion Studio to Control Tower,

please see screenshot below and advise.

error

Regards,
A


#2

Hi @asheeqoJmGJDIF, please check if you server profile in WorkFusion Studio is filled in. Menu: Window -Preferences - WorkFusion Studio - Server Profiles.


#3

Hi ashapkina,

the server profile is filled in,

still get the same error. when publishing to control tower. see screenshot below.


#4

The secret key values are empty, that’s why the publishing doesn’t work.
We already had one such issue reported after update from 2.0.0 to 2.0.1 using the Update option in the installer? Did you update to the new version the same way?


#5

Hi,

i’m still using 2.0.0, should i install the newer 2.0.1 in order for this to work.


#6

@asheeqoJmGJDIF Yes, please update to 2.0.1. Uninstall the current version before installing the new one.


#7

ok i will try that, thank you


#8

Just in case, before update, check if you have file default.profile in folder C:\RPAExpress\Studio\


#9

If the Studio failed to read the values during the first launch, the file can still contain these values, and you can manually insert them into the profile.


#10

HI @ashapkina,

Even I am getting same error message. Could not publish to server.


#11

Hi @narendra_purTG, do you get the same error: Unauthorized?
If you do, check that the server profile has secret key values. If it doesn’t, you will need to reinstall RPA Express.


#12

Hi @asheeqoJmGJDIF, did you have a chance to reinstall RPA Express? Did it solve the issue?


#13

issue resolved when i uninstalled older version an reinstalled 2.0.1. i am able to publish to control tower.


#14

I have uninstalled and reinstalled new version. Same error.