Unable to run process on control tower

Hi,
I’ve developed a process on recorder and it runs well.
However, i am not able to run on control tower, its always showing loading. I’m using latest version RPA
Express and running on VM with 10G RAM.
I’ve explored all options on the forum, export groovy and paste into control tower etc.
Appreciate if you can advice.

Thanks

Hi Pauline,
What do you mean by status “loading”? Could you please post a screenshot to see how the process looks?
Thank you.

Pauline,
Does the process result in any errors? Could you please send the event log

Also, please do not respond to forum@workfusion.com but here on the forum.
I found your response by accident.

Hi Alesia,
The % is at 0 for a very long time.
See attached.strong text
Thanks
Pauline

Pauline, please do not respond via email.
Please attach the event log in the thread below.
Thank you.

the error file attached, appreciate your help

I have a similar problem. All recordings run perfectly in the recorder. I can also succesfully publish them to the control tower. However, they fail to run in the control tower. This happened after updating to the newest RPAExpress version 1.2.0.
here is the error I get.


Would appreciate your help!
Kind regards
Anna

Anna, could you please export the event log to Excel and post here.
Thank you.

Here is the file
events_root_807f6916-b60d-42d1-bf57-acffd97d7531_2018-02-13 01_37_40.xlsx (5.4 KB)

Anna, did the recording run fine in 1.1.9?
Could you please send the recording, we’ll try to reproduce the error.

Thank you for your quick reply!
Yes, the recording worked perfectly in the version 1.1.9, both in the recorder and the control tower. It was also scheduled and worked fine.
Here is the zipped folder with the recording.
Cryptocurrency.7z (241.3 KB)
Do you also need the excel file I used with the Excel Actions?
CryptoCurrency.xlsx (7.9 KB)
thank you!

Anna, I think it might be connected to this bug in the Loop actions RPA Express Variable issue
Try running the recording directly from the recorder and see if it fails, too.

The recording is running without any problem from the recorder.
If the problem is caused by the curly brackets in the loop action, where do i need to delete them? I don’t have them anywhere in the recording.
Kindest regards
Anna

I actually thought the problem might be in the “item” variable in the For Each Loop action, it is not working correctly in this build.
If it is not, could you please send the logs located at C:\RPAExpress\Workfusion\tomcat\logs.
We’ll have a look.

Thank you.

Hi Anna, we re-checked this once again. The error occurs because of the item variable in the Loop action. We are releasing a hot fix where this issue will be solved.
Sorry for inconvenience.

@annavarshavets @pauline_yeo
We have released a hot fix for version 1.2.0. The bug with the “item” variable has been fixed.

Please keep in mind that the item variable has been replaced in the system with “element” variable, so you might need to change the variable name in certain actions in you recordings. We are very sorry for the troubles.

Please let me know if you still face these issues in the new build

Thank you for the quick solution.
Could you, please, help out with the other question - I cannot find the “element” variable when using the Web Element in the Loop. Am I missing something?


Thanks a lot in advance
Anna

Try adding another For Each action from the library and dragging the nested group of actions below it.
Does he element appear in the drop-down in this case?

Thanks a lot for the quick reply!
It works only if I create new recordings. I tried everything and did’t find the way to correct existing recording.

kindest regards
Anna

Alesia, thank you for the solution and the quick hot fix! Everything is working after reinstalling the newest RPAExpress.
With kindest regards

1 Like

Great! :grinning: