Unable to use Fieldref property in XPath

xpath
webelement

#1

Hi,

I am trying to fetch some information from our web app. However, the xpath of all the controls are changing dynamically for different policies but Fieldref property remains same for a particular field which we are unable to use in Xpath.

I have attached screenshot for the same. In the screenshot, the below highlighted portion are changing for every policy but the fieldref property(small rectangle at the bottom) remains same which we cannot use.

Kindly let me know if this possible or not via RPA?


#2

@gagan_oberoi

RPA Express 1.1.5 offers the Use element attribute option as described in https://kb.workfusion.com/display/RPAe/Web
Ypu can upgrade to this version and get the attribute in your Xpath.


#3

Thanks for the response,

I have gone through the link you have provided, They have mentioned about using the Xpath which in our case is changing for every policy, what we want to achieve is using the fieldref property which is consistent for a single checkbox throughout all the policies.


#4

//input[contains(@fieldref, ‘VALUE’)]


#5

@gagan_oberoi
If the ‘id’ is changed all the time, you can use ‘class’ instead in your Xpath.


#6

Hi,

I tried using checking and unchecking checkboxes on webpage. There is a checkbox on a webpage whose fieldref is “PolicyInput.PolicyTypeEO”… Please let me know how to check or uncheck this using webelement.

I have tested below 2 scenarios.

  1. //*[@fieldref=“PolicyInput.PolicyTypeEO”]
  2. //input[contains(@fieldref, ‘PolicyInput.PolicyTypeEO’)]

and first used Boolean variable to false—it did not work.
and also tried using number variable to 0–it also did not work.

Kindly let me know the workaround for the same if possible.


#7

@gagan_oberoi,

please post your recording here and the source code of the web page, thanks


#8

#9