Using URL from .csv file

Hi team,

I have some issues to use .csv file as input file properly:


control%20tower%20data%20

In Studio, I’m using ${list_url_ocr} as the address to be opened by Open Website .
list_url_ocr is defined by .csv file used as data input for my Business Process in Control Tower.
When I run the Business Process it seems to be unable to open the URL.

Could you please let me know what I’m doing wrong here? :slight_smile:

Hi @ValentinPM
The variable with the URL needs to be of String type, not List.

1 Like

Hi @ashapkina

I’ve modified the variable type, same issue…


list%20OCR%20URL%20as%20string%20code

Thank you for your support, it’s appreciated.

Can you open any of these URLs from the Studio?
Also, what error do you get in Control Tower?

In order to open these URL in studio I would have to change the action flow in recorder, right?
Or there’s a way to open .csv files from the studio directly?

Here’s the event log.
events_step_fa68a030-2467-4abf-9422-4f056010e05e_2019-09-26 14_55_36.xlsx (6.1 KB)

Let me know if I can provide you with any information required to solve my issue.
And once again, thank you four your support.

businesscards.csv (1.5 KB)

I guess the .csv might be useful.

No, no need to change the recording. You can just use one of the URLs as a default value and run the recording with it to test.

You need to add http:// in the URLs.
Also, make sure that the policy for the bucket is set to Read and Write, not Read Only.

Good morning @ashapkina,
I hope you’re doing well. :slight_smile:

Studio can open the URL properly when I use the URL as the default value for my variable.

I’ve updated the .csv as requested (attached). And I’ve verified that the file is not Read Only.

I’ve run the process earlier this morning but the BP is still unable to open the URL from the .csv

businesscards.csv (1.5 KB) .

events_step_924d2f42-145d-44e8-b0e6-3eb99efd89b5_2019-09-30 08_37_59.xlsx (10.3 KB)

Any advice would be appreciated :smiley:
Thank you.

Do you run it from the local Control Tower installed on your machine?

@ashapkina Yes, I do.

1 Like

Try deleting the extra characters after .png in the links as described in the guide https://kb.workfusion.com/display/RPAe/File+Storage#FileStorage-CreatingInputDataFiles

Let me know if it doesn’t help.

1 Like

Unfortunately, this is not solving the issue.

Here’s my .csv
businesscards.csv (250 Bytes)

My bucket policy is Read and Write

Why do you have prefix raw in the policy?
You need to leave the asterisk to allow access to all files.

@ashapkina, corrected.

The issue remains.

Do you get the same error in the event log?

image “Step name ‘OCR Cards’ has failed. Reason: '[urn:uuid:E0F0D2E9851212F91A15698567159764] robotics-flow executePlugin exception: [nodeId=http://127.0.0.1:15410] org.webharvest.exception.ScriptException:
Config line 11: script block
org.openqa.selenium.WebDriverException: unknown error: unhandled inspector error: {”“code”":-32000,"“message”":"“Cannot navigate to invalid URL”"}
(Session info: chrome=76.0.3809.132)
(Driver info: chromedriver=2.44.609538 (b655c5a60b0b544917107a59d4153d4bf78e1b90),platform=Windows NT 10.0.17134 x86_64) (WARNING: The server did not provide any stacktrace information)
Command duration or timeout: 0 milliseconds
Build info: version: ‘9.4.0.3’, revision: ‘abf2ebe0f1’, time: ‘2019-05-29T13:21:06.482Z’
System info: host: ‘PLKRBDEXWWESL’, ip: ‘10.203.97.72’, os.name: ‘Windows 10’, os.arch: ‘amd64’, os.version: ‘10.0’, java.version: ‘1.8.0_121’
Driver info: org.openqa.selenium.remote.RemoteWebDriver
Capabilities [{mobileEmulationEnabled=false, hasTouchScreen=false, …"

Can you share your business process here to have a look?

Business Process flow

OCR Cards step
OCR Cards.txt (2.8 KB)

.csv file used
businesscards.csv (250 Bytes)

To share the recording, you can zip the folder with it and attach the archive here.

My bad.

Power_user_assignment.zip (29.0 KB)